aboutsummaryrefslogtreecommitdiffstats
path: root/community/ii
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-04-14 15:43:01 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-04-14 15:48:04 +0200
commit2bc9d0df4346608536c4536ef95d1410153503af (patch)
tree354c135451204fa77f0cb9e696aa869552cf793d /community/ii
parent50ab370f560c3f4c29bf69bc8a00c780052c3ec3 (diff)
community/ii: move from testing
Diffstat (limited to 'community/ii')
-rw-r--r--community/ii/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/ii/APKBUILD b/community/ii/APKBUILD
new file mode 100644
index 00000000000..1a199a12a74
--- /dev/null
+++ b/community/ii/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: lemon <lemon@bitmessage.ch>
+# Maintainer: lemon <lemon@bitmessage.ch>
+pkgname=ii
+pkgver=1.8
+pkgrel=2
+pkgdesc="Minimalist FIFO and filesystem-based IRC client"
+url="https://tools.suckless.org/ii"
+arch="all"
+license="MIT"
+options="!check" # upstream doesn't have a test suite
+subpackages="$pkgname-doc"
+source="https://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ sed -i "$builddir/config.mk" \
+ -e '/CFLAGS/{s/-Os //;s/=/+=/}' \
+ -e '/LDFLAGS/{s/-s //;s/=/+=/}'
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="2b41a0611ac76612c9333e8490709ee22d17506f0c5d7e680a0d8f3f8b511bd5b279555cf609c1543aba71948819369a3c306b1168086890aa49c145b7860e17 ii-1.8.tar.gz"