aboutsummaryrefslogtreecommitdiffstats
path: root/community/imagemagick6
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-11 01:53:38 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-11 01:53:38 +0200
commitc4682db5295fd557cd42696b09031ee4d8a63be0 (patch)
tree031a017dcec376cfcdcf0616ca7325753e73010e /community/imagemagick6
parenta33dd6dc0c9664708900eedf0002b5fbbaa07c77 (diff)
downloadaports-c4682db5295fd557cd42696b09031ee4d8a63be0.tar.gz
aports-c4682db5295fd557cd42696b09031ee4d8a63be0.tar.bz2
aports-c4682db5295fd557cd42696b09031ee4d8a63be0.tar.xz
community/imagemagick6: move from testing
Diffstat (limited to 'community/imagemagick6')
-rw-r--r--community/imagemagick6/APKBUILD109
1 files changed, 109 insertions, 0 deletions
diff --git a/community/imagemagick6/APKBUILD b/community/imagemagick6/APKBUILD
new file mode 100644
index 0000000000..cde9fddbd8
--- /dev/null
+++ b/community/imagemagick6/APKBUILD
@@ -0,0 +1,109 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=imagemagick6
+_pkgname=ImageMagick
+pkgver=6.9.9.18
+_pkgver=${pkgver%.*}-${pkgver##*.}
+_abiver=${pkgname#imagemagick}
+pkgrel=0
+pkgdesc="A collection of tools and libraries for many image formats (legacy version $_abiver)"
+url="https://www.imagemagick.org/"
+arch="all"
+license="custom"
+options="libtool"
+depends_dev="!${pkgname%$_abiver}-dev"
+makedepends="fontconfig-dev freetype-dev ghostscript-dev lcms2-dev
+ libjpeg-turbo-dev libpng-dev librsvg-dev libtool libxml2-dev tiff-dev
+ zlib-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
+source="http://www.imagemagick.org/download/releases/$_pkgname-$_pkgver.tar.xz"
+builddir="$srcdir/$_pkgname-$_pkgver"
+
+prepare() {
+ default_prepare
+
+ if [ "${pkgver%%.*}" != "$_abiver" ]; then
+ error "This abuild is for major version $_abiver, but pkgver=$pkgver!"
+ return 1
+ fi
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --program-suffix="-$_abiver" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-docs \
+ --disable-static \
+ --with-threads \
+ --without-x \
+ --without-perl \
+ --with-tiff \
+ --with-png \
+ --with-rsvg \
+ --with-gslib \
+ --with-gs-font-dir=/usr/share/fonts/Type1 \
+ --with-modules \
+ --with-xml
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+
+ if [ ! -e "$pkgdir"/usr/lib/libMagickCore-$_abiver.Q16.so ]; then
+ error "Has ABI verision changed? (current is $_abiver)"
+ return 1
+ fi
+
+ # We cannot let abuild delete the *.la files due to we need *.la
+ # for the modules.
+ rm "$pkgdir"/usr/lib/*.la
+
+ find "$pkgdir" -name '.packlist' -o -name 'perllocal.pod' \
+ -o -name '*.bs' -delete
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+dev() {
+ default_dev
+
+ cd "$subpkgdir"
+
+ mkdir -p ./usr/bin
+ mv "$pkgdir"/usr/bin/*-config-$_abiver ./usr/bin/
+
+ cd ./usr/bin
+ local f; for f in *; do
+ ln -s $f ${f%-$_abiver}
+ done
+}
+
+libs() {
+ default_libs
+
+ cd "$subpkgdir"
+
+ mv "$pkgdir"/etc .
+ mv "$pkgdir"/usr/lib/* ./usr/lib/
+ mv "$pkgdir"/usr/share ./usr/
+}
+
+_cxx() {
+ pkgdesc="ImageMagick Magick++ library (C++ bindings)"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libMagick++*.so.* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="b18733e01c3f41a221a691ceb992bb2e7ecabbdd1b4765c5dd46f00c2047db8534acee9659aed55786baa00062946353bd02ac60b0609caf21f87fb34a40d290 ImageMagick-6.9.9-18.tar.xz"