aboutsummaryrefslogtreecommitdiffstats
path: root/community/iouyap/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-28 16:27:14 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-28 16:28:50 +0000
commitf14c400d1661e819aba8e99e80bf7605b6b19a2a (patch)
treecc3b6ad283b2ed0900321d12daeb949c1f782445 /community/iouyap/APKBUILD
parent0c1064dd88d91662b81862556556cee9f807abde (diff)
community/iouyap: add simple check and modernize
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/iouyap/APKBUILD')
-rw-r--r--community/iouyap/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/iouyap/APKBUILD b/community/iouyap/APKBUILD
index 13c4e617591..d2828f57169 100644
--- a/community/iouyap/APKBUILD
+++ b/community/iouyap/APKBUILD
@@ -2,32 +2,33 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=iouyap
pkgver=0.97
-pkgrel=0
+pkgrel=1
pkgdesc="Bridge IOU to UDP, TAP and Ethernet."
url="https://github.com/GNS3/iouyap"
arch="all"
license="GPL3"
makedepends="$depends_dev linux-headers bison flex bsd-compat-headers"
-options="!check"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz
musl-fixes.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
make
}
+check() {
+ cd "$builddir"
+ ./iouyap -help > /dev/null
+}
+
package() {
cd "$builddir"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="d874e11fd32c3348c1d5f92d60274f72 iouyap-0.97.tar.gz
-22b79954e6520b01c2b3ed77d41ea49d musl-fixes.patch"
-sha256sums="181850a4ce73a4d4035f9eb39b2656ae31d360f18b577ee65f5149132da3eccf iouyap-0.97.tar.gz
-4849669e70974e563ca728c047dc560ea50696c1645a8139e5bc5d3192ef2b21 musl-fixes.patch"
sha512sums="c6b3779bb1a0a004085796bb72cc9824ef3ef04db70cef13a12a2f33676fca11d721c1dcd81a4caff67ce56511624f293c89579705434a24332f672a8dfa2d33 iouyap-0.97.tar.gz
311a7e330baa5cb762390e941d4f7c48385feef0e6cddb0252307a16fa69d5515408dcfe2b4f9a8523a05b5c9edd79df4509d51a8ac0163959a6a4f9e61f6e4a musl-fixes.patch"