aboutsummaryrefslogtreecommitdiffstats
path: root/community/irrlicht
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-09 10:41:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-09 10:41:53 +0000
commitfdf726d310e100331ce7929ad4552b8a28ee5430 (patch)
tree8058b2a98e634030764ac905da122e43dc42f0d1 /community/irrlicht
parentbbaa3499a8032234fb44af5b951e8e73d10c57e2 (diff)
community/irrlicht: move from main
Diffstat (limited to 'community/irrlicht')
-rw-r--r--community/irrlicht/APKBUILD71
-rw-r--r--community/irrlicht/irrlicht-1.8.1-config.patch31
-rw-r--r--community/irrlicht/irrlicht-1.8.1-mesa-10.x.patch40
-rw-r--r--community/irrlicht/irrlicht-1.8.1-sysctl.patch13
4 files changed, 155 insertions, 0 deletions
diff --git a/community/irrlicht/APKBUILD b/community/irrlicht/APKBUILD
new file mode 100644
index 00000000000..8e7644f661d
--- /dev/null
+++ b/community/irrlicht/APKBUILD
@@ -0,0 +1,71 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
+pkgname=irrlicht
+pkgver=1.8.1
+pkgrel=2
+pkgdesc="High performance realtime 3D engine written in C++"
+url="http://irrlicht.sourceforge.net"
+arch="all"
+license="ZLIB"
+depends=
+makedepends="mesa-dev jpeg-dev bzip2 libpng-dev zlib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip
+ irrlicht-1.8.1-mesa-10.x.patch
+ irrlicht-1.8.1-config.patch
+ irrlicht-1.8.1-sysctl.patch
+"
+_builddir="$srcdir"/$pkgname-$pkgver/
+
+prepare() {
+ local i
+ cd "$srcdir"/$pkgname-$pkgver/
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"/source/Irrlicht/
+ make sharedlib || return 1
+
+ #from arch pkgbuild: example build helper
+ ln -s libIrrlicht.so.$pkgver "$srcdir"/$pkgname-$pkgver/lib/Linux/libIrrlicht.so
+}
+
+package() {
+ cd "$_builddir"
+
+ mkdir -p "$pkgdir"/usr/lib
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ mkdir -p "$pkgdir"/usr/include/$pkgname
+
+ install -m644 readme.txt "$pkgdir"/usr/share/licenses/$pkgname
+
+ #from arch pkgbuild: install docs
+ cp -r doc/* "$pkgdir"/usr/share/doc/$pkgname
+
+ install -m755 "$_builddir"/lib/Linux/libIrrlicht.so.$pkgver "$pkgdir"/usr/lib
+ cd "$pkgdir"/usr/lib
+ ln -s libIrrlicht.so.$pkgver libIrrlicht.so
+ ln -s libIrrlicht.so.$pkgver libIrrlicht.so.1.8
+
+ install -m644 "$_builddir"/include/* "$pkgdir"/usr/include/$pkgname
+}
+
+md5sums="f4f7fa33bd1060eb0dd51dcd66b0f6e3 irrlicht-1.8.1.zip
+b83f74be3507b9a0488ac15892456ac9 irrlicht-1.8.1-mesa-10.x.patch
+f3a3616ae60d19a44c58e71d70e52186 irrlicht-1.8.1-config.patch
+eb2edf8959d587f590e978b4e93b3663 irrlicht-1.8.1-sysctl.patch"
+sha256sums="814bb90116d5429449ba1d169e2cbff881c473b7eada4c2447132bc4f4a6e97b irrlicht-1.8.1.zip
+d17e8084cb5b458aef85a136b6366e07e615b8dcca18fd7f66a988886d7ab750 irrlicht-1.8.1-mesa-10.x.patch
+67393d31171dfdaf34dc0874c9bece9c25d58589f4532e23487a20b5c33c514e irrlicht-1.8.1-config.patch
+71a372624332d8c72c215565e1d66da1ff8eb85cefdbe4f0c8c949fb6aa74e8d irrlicht-1.8.1-sysctl.patch"
+sha512sums="93390c162e5a8edb231588d47dc421c24d21a34e833df1f3b92c85a9e8ef4a96a61d854e05eedb37f88f7f02821059e78a40a52cbc8e39356c4d36b17775dfbb irrlicht-1.8.1.zip
+44c16419c07597ba6d06d66057fbe2ab86e7b02b5dcdf458678b4ea87f6f721840da951ae4df59c983e1da83abdbe45f82e44a6a311bd42eb94d93dfd5aa437c irrlicht-1.8.1-mesa-10.x.patch
+8bb80040b90bc3d4b8d3f9c5c3f39f3cc2d09fef663338e0994788bc1cd9254b9e7465ac2b344d4532a83c2dc27a8bed9ef5bc26824ef91e4e0159f6db2216e1 irrlicht-1.8.1-config.patch
+a25887c46990620271168f3c1ff42e3ff7bd577d5e986803f067942b7f43d63428ebbbf29d3956765b3199da731b151a39d3ee6b8e5bdab189710ef8fb9595e5 irrlicht-1.8.1-sysctl.patch"
diff --git a/community/irrlicht/irrlicht-1.8.1-config.patch b/community/irrlicht/irrlicht-1.8.1-config.patch
new file mode 100644
index 00000000000..0320d939690
--- /dev/null
+++ b/community/irrlicht/irrlicht-1.8.1-config.patch
@@ -0,0 +1,31 @@
+diff --git a/include/IrrCompileConfig.h b/include/IrrCompileConfig.h
+index 2fa2423..e7c287e 100644
+--- a/include/IrrCompileConfig.h
++++ b/include/IrrCompileConfig.h
+@@ -249,7 +249,7 @@ the engine will no longer read .jpeg images. */
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
++//#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #undef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #endif
+@@ -265,7 +265,7 @@ the engine will no longer read .png images. */
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
++//#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #ifdef NO_IRR_USE_NON_SYSTEM_LIB_PNG_
+ #undef _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #endif
+@@ -602,7 +602,7 @@ ones. */
+ /** If this is commented out, Irrlicht will try to compile using the zlib
+ installed on the system. This is only used when _IRR_COMPILE_WITH_ZLIB_ is
+ defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
++//#define _IRR_USE_NON_SYSTEM_ZLIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_ZLIB_
+ #undef _IRR_USE_NON_SYSTEM_ZLIB_
+ #endif
diff --git a/community/irrlicht/irrlicht-1.8.1-mesa-10.x.patch b/community/irrlicht/irrlicht-1.8.1-mesa-10.x.patch
new file mode 100644
index 00000000000..e90ff36443a
--- /dev/null
+++ b/community/irrlicht/irrlicht-1.8.1-mesa-10.x.patch
@@ -0,0 +1,40 @@
+From 244d00280c1b082ca164f92337773e9e4e1a3898 Mon Sep 17 00:00:00 2001
+From: hiker <henrichsjoerg@mgail.com>
+Date: Wed, 26 Feb 2014 11:13:03 +1100
+Subject: [PATCH] Applied patch from jpirie for fixing mesa 10 compilation
+ problems.
+
+--- irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
++++ irrlicht-1.8.1/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -21,6 +21,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #include "wglext.h"
+@@ -35,6 +36,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
+@@ -48,6 +50,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL/SDL_video.h>
+ #include <SDL/SDL_opengl.h>
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+@@ -60,6 +63,7 @@
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
+ #include "glxext.h"
diff --git a/community/irrlicht/irrlicht-1.8.1-sysctl.patch b/community/irrlicht/irrlicht-1.8.1-sysctl.patch
new file mode 100644
index 00000000000..5ab99a9667e
--- /dev/null
+++ b/community/irrlicht/irrlicht-1.8.1-sysctl.patch
@@ -0,0 +1,13 @@
+diff --git a/source/Irrlicht/COSOperator.cpp b/source/Irrlicht/COSOperator.cpp
+index 0899d1d..d0e25f4 100644
+--- a/source/Irrlicht/COSOperator.cpp
++++ b/source/Irrlicht/COSOperator.cpp
+@@ -13,7 +13,7 @@
+ #include <unistd.h>
+ #ifndef _IRR_SOLARIS_PLATFORM_
+ #include <sys/types.h>
+-#include <sys/sysctl.h>
++//#include <sys/sysctl.h>
+ #endif
+ #endif
+