aboutsummaryrefslogtreecommitdiffstats
path: root/community/jattach
diff options
context:
space:
mode:
authorjchipmunk <andrey.pustovetov@gmail.com>2018-08-24 20:22:49 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 10:43:59 +0000
commitc982d4289aff702be2e3fff579b34b450185695c (patch)
tree0d346e5c7eab8f0f56fe5e4326d5b932a8b0c102 /community/jattach
parent028b7265ba2411859c39a604d2e0178e26f6209f (diff)
testing/jattach: move to community
Diffstat (limited to 'community/jattach')
-rw-r--r--community/jattach/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/jattach/APKBUILD b/community/jattach/APKBUILD
new file mode 100644
index 00000000000..58aeed95846
--- /dev/null
+++ b/community/jattach/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Andrey Pustovetov <andrey.pustovetov@gmail.com>
+# Maintainer: Andrey Pustovetov <andrey.pustovetov@gmail.com>
+pkgname=jattach
+pkgver=1.4
+pkgrel=0
+pkgdesc="JVM dynamic attach utility"
+url="https://github.com/apangin/jattach"
+arch="all"
+license="Apache-2.0"
+options="!check" # upstream doesn't have a test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/apangin/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ install -Dm0755 "$builddir/build/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+sha512sums="ea539e8217448495cd442e0f33dbcdefe81fbd49a0ab60ccf53d2346b782506e02c5c5b1c151b76168df2fcb5fc916bba3d8b98b740c8de90ddb696165855b46 jattach-1.4.tar.gz"