aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsonrpc-glib/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2021-05-26 18:47:48 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2021-05-26 18:47:48 +0000
commit6ebd33a64c0d39af7d8f26ab9de2e29d58977b08 (patch)
treed36ab9bc61cba15c555f0deace258963a5ad5a5a /community/jsonrpc-glib/APKBUILD
parent44547bd701da94e1564ce31b58cf178069e74722 (diff)
community/jsonrpc-glib: disable gtk-doc
It's broken at the moment: > ERROR: Error in gtkdoc helper script: > cc1: error: @BUILD_ROOT@/src/.: No such file or directory > [-Werror=missing-include-dirs] > cc1: error: @SOURCE_ROOT@/src/.: No such file or directory > [-Werror=missing-include-dirs] > cc1: some warnings being treated as errors
Diffstat (limited to 'community/jsonrpc-glib/APKBUILD')
-rw-r--r--community/jsonrpc-glib/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/jsonrpc-glib/APKBUILD b/community/jsonrpc-glib/APKBUILD
index 9c8f00e8b60..1a71d5f9ccf 100644
--- a/community/jsonrpc-glib/APKBUILD
+++ b/community/jsonrpc-glib/APKBUILD
@@ -7,14 +7,14 @@ pkgdesc="Library to communicate using the JSON-RPC 2.0 specification"
url="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
arch="all"
license="GPL-3.0-or-later"
-makedepends="gtk+3.0-dev vala gobject-introspection-dev gtk-doc meson json-glib-dev"
+makedepends="gtk+3.0-dev vala gobject-introspection-dev meson json-glib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz
disable-flaky-test.patch"
build() {
abuild-meson \
- -Denable_gtk_doc=true \
+ -Denable_gtk_doc=false \
. output
meson compile ${JOBS:+-j ${JOBS}} -C output
}