aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia/0001-hardened.patch
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-05-22 18:40:14 +0200
committerShiz <hi@shiz.me>2017-05-22 18:40:42 +0200
commit93ad08e10334b4133743f9042e8b9aff9583b23f (patch)
tree0e1d693037ed4e28451535c45887947e28027c23 /community/julia/0001-hardened.patch
parent7039b303d95e672b466926ed93c105e2dc7e2db2 (diff)
community/julia: move from testing
Diffstat (limited to 'community/julia/0001-hardened.patch')
-rw-r--r--community/julia/0001-hardened.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/julia/0001-hardened.patch b/community/julia/0001-hardened.patch
new file mode 100644
index 00000000000..2984356c7b8
--- /dev/null
+++ b/community/julia/0001-hardened.patch
@@ -0,0 +1,29 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sun, 05 Jun 2016 14:11:00 +0200
+Subject: [PATCH] Disable PaX memory protection for julia binary
+--- a/Makefile
++++ b/Makefile
+@@ -71,7 +71,13 @@
+ julia-sysimg-debug : julia-inference julia-ui-debug
+ @$(MAKE) $(QUIET_MAKE) $(build_private_libdir)/sys-debug.$(SHLIB_EXT) JULIA_BUILD_MODE=debug
+
+-julia-debug julia-release : julia-% : julia-ui-% julia-sysimg-% julia-symlink julia-libccalltest
++julia-pax-release : julia-ui-release
++ paxmark m $(JULIA_EXECUTABLE_release)
++
++julia-pax-debug : julia-ui-debug
++ paxmark m $(JULIA_EXECUTABLE_debug)
++
++julia-debug julia-release : julia-% : julia-ui-% julia-pax-% julia-sysimg-% julia-symlink julia-libccalltest
+
+ debug release : % : julia-%
+
+@@ -527,7 +533,7 @@
+ test testall testall1 test clean distcleanall cleanall clean-* \
+ run-julia run-julia-debug run-julia-release run \
+ install binary-dist light-source-dist.tmp light-source-dist \
+- dist full-source-dist source-dist
++ dist full-source-dist source-dist julia-pax-release julia-pax-debug
+
+ test: check-whitespace $(JULIA_BUILD_MODE)
+ @$(MAKE) $(QUIET_MAKE) -C test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE)