aboutsummaryrefslogtreecommitdiffstats
path: root/community/kate/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-20 18:36:20 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-21 18:12:22 +0100
commitc7a1f20490e2882233bfdfa682040d3cb0ffd967 (patch)
treea2b7e4154d67dc0ad64867ff7507b2883604688b /community/kate/APKBUILD
parent20b13d17d07ee2958a377d95f3ad14826ff9ddf9 (diff)
community/*: make CMake and meson respect our C{,PP,XX}FLAGS
See: https://lists.alpinelinux.org/~alpine/devel/%3C2896c13070c508a49cbaa72c8fb7f34ea947358b.camel%40cogitri.dev%3E
Diffstat (limited to 'community/kate/APKBUILD')
-rw-r--r--community/kate/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/kate/APKBUILD b/community/kate/APKBUILD
index c8d4455e8ea..0548130cc4b 100644
--- a/community/kate/APKBUILD
+++ b/community/kate/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kate
pkgver=19.12.2
-pkgrel=0
+pkgrel=1
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/applications/utilities/org.kde.kate"
pkgdesc="A multi-document, multi-view text editor"
@@ -21,7 +21,7 @@ prepare() {
build() {
cd "$builddir"/build/kate
cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_kwrite=FALSE
@@ -29,7 +29,7 @@ build() {
cd "$builddir"/build/kwrite
cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_kate=FALSE \