aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot-resolver
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-04 14:13:27 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-07 16:53:06 +0000
commit656a7b9e242fcb0ecc7869ac1224aeb36c05569b (patch)
tree50f05f0f265423b15e71af68706274d613b4cb3d /community/knot-resolver
parenta7babc487fb2433a1b9c70e3408250e244e90acb (diff)
community/knot-resolver: use dns-root-hints
Diffstat (limited to 'community/knot-resolver')
-rw-r--r--community/knot-resolver/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/knot-resolver/APKBUILD b/community/knot-resolver/APKBUILD
index 05e7f4b8470..03345ae780d 100644
--- a/community/knot-resolver/APKBUILD
+++ b/community/knot-resolver/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: tcely <knot-resolver+aports@tcely.33mail.com>
pkgname=knot-resolver
pkgver=3.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Minimalistic caching DNS resolver implementation"
url="https://www.knot-resolver.cz/"
# luajit is not available for disabled arches
@@ -10,7 +10,7 @@ arch="all !s390x"
license="GPL-3.0"
pkgusers="kresd"
pkggroups="kresd"
-depends="lua5.1-sec lua5.1-socket"
+depends="dns-root-hints lua5.1-sec lua5.1-socket"
depends_dnstap=""
depends_dnstap_dev="fstrm-dev protobuf-c-dev"
depends_http="$pkgname lua5.1-http"
@@ -58,6 +58,9 @@ package() {
mv ./etc/$pkgname/config* ./usr/share/doc/$pkgname/
chmod 644 ./usr/share/doc/$pkgname/*
+ rm -f ./etc/$pkgname/root.hints
+ ln -s ../../usr/share/dns-root-hints/named.root ./etc/$pkgname/root.hints
+
install -m 640 -o root -g kresd "$srcdir"/config \
./etc/$pkgname/config