aboutsummaryrefslogtreecommitdiffstats
path: root/community/lastpass-cli
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-24 10:37:38 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-24 10:43:42 +0200
commit299fa8ec9c02f940cad65d17448276f5f2633b2d (patch)
treed65a81afb1099c53232cb8ef6fb407f51662c17a /community/lastpass-cli
parentd7906ac4e6742f1b99d8f354c3307ffe1fb068bf (diff)
community/lastpass-cli: upgrade to 1.2.1 and misc changes
moved to community added checks fixes #7956
Diffstat (limited to 'community/lastpass-cli')
-rw-r--r--community/lastpass-cli/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/lastpass-cli/APKBUILD b/community/lastpass-cli/APKBUILD
new file mode 100644
index 00000000000..8cf6e8a1c53
--- /dev/null
+++ b/community/lastpass-cli/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=lastpass-cli
+pkgver=1.2.1
+pkgrel=0
+pkgdesc="LastPass command line interface tool"
+url="https://lastpass.com/"
+arch="all"
+license="GPL2"
+makedepends="libressl-dev curl-dev libxml2-dev asciidoc cmake"
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/${pkgname/-*/}/$pkgname/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make all
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install install-doc
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+bashcomp() {
+ depends="bash"
+ pkgdesc="Bash completions for $pkgname"
+ install -Dm 644 "$builddir"/contrib/lpass_bash_completion \
+ "$subpkgdir"/usr/share/bash-completion/completions/lpass
+}
+
+sha512sums="c7c9f20dbc083873b815834320828a30a1c488571efbfc5aea47c3bd2073819d713810c785855d4c0c208e1b95aa0e5fc550a0b6b5c0f787eca1f54589e18e62 lastpass-cli-1.2.1.tar.gz"