aboutsummaryrefslogtreecommitdiffstats
path: root/community/libaccounts-glib/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-18 19:44:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-20 11:12:48 +0000
commit279b1665ec6150f80c6e8d0101f1ecc0a5faa9b4 (patch)
tree1869c689ac831bb830f128765603ac1c83749a53 /community/libaccounts-glib/APKBUILD
parentfec8fe13ffbf416ea422ee4ba487fff4a85aecd8 (diff)
community/libaccounts-glib: upgrade to 1.25
Diffstat (limited to 'community/libaccounts-glib/APKBUILD')
-rw-r--r--community/libaccounts-glib/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/libaccounts-glib/APKBUILD b/community/libaccounts-glib/APKBUILD
index 52bf5433d3a..9e8d591563c 100644
--- a/community/libaccounts-glib/APKBUILD
+++ b/community/libaccounts-glib/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libaccounts-glib
-pkgver=1.24
-pkgrel=2
+pkgver=1.25
+pkgrel=0
arch="all"
url="https://gitlab.com/accounts-sso/libaccounts-glib"
pkgdesc="GLib-based client library for the accounts database"
@@ -15,16 +15,19 @@ options="!check" # Requires a systemd feature
builddir="$srcdir/$pkgname-VERSION_$pkgver"
build() {
- meson build --prefix=/usr --buildtype=plain
- ninja -C build
+ meson \
+ --prefix=/usr \
+ --buildtype=plain \
+ . output
+ ninja -C output
}
check() {
- meson test -C build
+ meson test -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c libaccounts-glib-VERSION_1.24.tar.gz"
+sha512sums="cc8b493d246f99300ee614fed93258378ecdbe9c518a958a59827ee8f74559b1ee3683acfb85f59aa91390275497fb35041da2be47f27f24f96e1efd5d6d2e20 libaccounts-glib-VERSION_1.25.tar.gz"