aboutsummaryrefslogtreecommitdiffstats
path: root/community/libaccounts-glib/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-27 14:59:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 15:49:40 +0100
commit6f605e073526b7315716debe3ee8cf9de9bbd561 (patch)
tree2f13c05b0cb9391765c0dff8e4c9262ddc9b9d54 /community/libaccounts-glib/APKBUILD
parentcaf3e7f22c332e6567e098d5ee2b4e7cfd2bf096 (diff)
community/libaccounts-glib: move from testing
Diffstat (limited to 'community/libaccounts-glib/APKBUILD')
-rw-r--r--community/libaccounts-glib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/libaccounts-glib/APKBUILD b/community/libaccounts-glib/APKBUILD
new file mode 100644
index 00000000000..836971251d6
--- /dev/null
+++ b/community/libaccounts-glib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libaccounts-glib
+pkgver=1.24
+pkgrel=1
+arch="all"
+url="https://gitlab.com/accounts-sso/libaccounts-glib"
+pkgdesc="GLib-based client library for the accounts database"
+license="LGPL-2.1-or-later"
+depends_dev="libxml2-dev sqlite-dev check-dev py3-gobject3 gobject-introspection-dev"
+makedepends="$depends_dev meson ninja vala python3 gtk-doc glib-dev"
+source="https://gitlab.com/accounts-sso/libaccounts-glib/-/archive/VERSION_$pkgver/libaccounts-glib-VERSION_$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # Requires a systemd feature
+builddir="$srcdir/$pkgname-VERSION_$pkgver"
+
+build() {
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c libaccounts-glib-VERSION_1.24.tar.gz"