aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcoap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-25 20:12:41 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-25 20:12:41 +0200
commit9bd2e86a0eaaea55ab7ab7015f76524afe8e4249 (patch)
treedf14006075b081818e7b6b2cbf32920d494e7ea4 /community/libcoap
parent7ef01101d87f54b480069a11a517fe1260886733 (diff)
community/libcoap: move from testing
Diffstat (limited to 'community/libcoap')
-rw-r--r--community/libcoap/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/libcoap/APKBUILD b/community/libcoap/APKBUILD
new file mode 100644
index 00000000000..68906089c58
--- /dev/null
+++ b/community/libcoap/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=libcoap
+pkgver=4.1.2
+pkgrel=0
+pkgdesc="A CoAP (RFC 7252) implementation"
+url="https://github.com/obgm/libcoap"
+arch="all"
+license="BSD GPL2+"
+depends=""
+depends_dev=""
+makedepends="automake autoconf libtool asciidoc"
+checkdepends="cunit-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/obgm/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-tests
+ make
+}
+
+check() {
+ "$builddir"/tests/testdriver
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 CONTRIBUTE AUTHORS ChangeLog NEWS README.md TODO \
+ "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="151f40cdacddf25bdffe367b4f1e3bf295445eac966db7bcf6692047cd9d5476b726f08c8d1de7dbe4ebe2477162b4df5e6c121e24eac79f9a4041ab2a646be6 libcoap-4.1.2.tar.gz"