aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgnt/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-01 00:12:26 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-07 11:37:38 +0200
commit5d48f6fc0d51f6795c99bc4ce8d0c9319453123e (patch)
tree7ccaa013f348dc97a6ec1cd8679d21ed0c68ff24 /community/libgnt/APKBUILD
parent2d131471b194f4d478c1df227f6405d87b3462cf (diff)
community/libgnt: use abuild-meson & meson compile/test/install
Diffstat (limited to 'community/libgnt/APKBUILD')
-rw-r--r--community/libgnt/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/libgnt/APKBUILD b/community/libgnt/APKBUILD
index e9db350d2a8..b76fdfad30e 100644
--- a/community/libgnt/APKBUILD
+++ b/community/libgnt/APKBUILD
@@ -13,22 +13,16 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/project/pidgin/libgnt/$pkgver/libgnt-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
- . output
- ninja -C output
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="0d9c5550374696a0e6ede5246cda3c372d7055d21b9ffaf10be88d6a469bdf18c7dd1113ec612acf4889c0e5686ea87bb0e8348ca8985fd5ff8913afc5813b38 libgnt-2.14.0.tar.xz"