aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgweather
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-03 08:08:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-03 08:53:46 +0000
commit2afac8547dd23ef8668e439eaa8f3e9f9314c548 (patch)
treee424968950b7bfebaafdf8a77e53159132c3e93b /community/libgweather
parent2f5e9721db834988a5415cb4b9b573eefded6c6b (diff)
community/libgweather: move from main
Diffstat (limited to 'community/libgweather')
-rw-r--r--community/libgweather/APKBUILD47
-rw-r--r--community/libgweather/libgweather.post-install7
-rw-r--r--community/libgweather/libgweather.post-upgrade7
-rw-r--r--community/libgweather/libgweather.pre-deinstall7
4 files changed, 68 insertions, 0 deletions
diff --git a/community/libgweather/APKBUILD b/community/libgweather/APKBUILD
new file mode 100644
index 00000000000..dc24ad47e2b
--- /dev/null
+++ b/community/libgweather/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=libgweather
+pkgver=2.30.3
+pkgrel=3
+pkgdesc="GNOME weather library"
+url="http://www.gnome.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="gtk+-dev libsoup-dev libxml2-dev gconf-dev"
+makedepends="$depends_dev"
+install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zoneinfo-dir=. \
+ --disable-scrollkeeper \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="bf6a0a05051341ecb250f332e3edfb88 libgweather-2.30.3.tar.bz2"
diff --git a/community/libgweather/libgweather.post-install b/community/libgweather/libgweather.post-install
new file mode 100644
index 00000000000..c9c323078a0
--- /dev/null
+++ b/community/libgweather/libgweather.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/libgweather/libgweather.post-upgrade b/community/libgweather/libgweather.post-upgrade
new file mode 100644
index 00000000000..c9c323078a0
--- /dev/null
+++ b/community/libgweather/libgweather.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/libgweather/libgweather.pre-deinstall b/community/libgweather/libgweather.pre-deinstall
new file mode 100644
index 00000000000..30dad25f8d4
--- /dev/null
+++ b/community/libgweather/libgweather.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gweather.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done