aboutsummaryrefslogtreecommitdiffstats
path: root/community/libosinfo
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-29 23:29:54 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-02-01 17:32:17 +0000
commit66a78f1b9d5ec26a0c22be7f8e90d003c33bd5a9 (patch)
tree47b672a7f148f4e7ee44cf360292271026ec7cc1 /community/libosinfo
parentded35da9ddde9ef3036e21f5dc3cd28b989344a9 (diff)
community/libosinfo: modernize and add check
Diffstat (limited to 'community/libosinfo')
-rw-r--r--community/libosinfo/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/libosinfo/APKBUILD b/community/libosinfo/APKBUILD
index 2fe2e03af1c..655839646e9 100644
--- a/community/libosinfo/APKBUILD
+++ b/community/libosinfo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libosinfo
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A library for managing OS information for virtualization"
url="http://libosinfo.org/"
arch="all"
@@ -12,7 +12,7 @@ makedepends="glib-dev libsoup-dev libxml2-dev libxslt-dev vala intltool
subpackages="$pkgname-dev $pkgname-doc"
source="https://releases.pagure.org/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -27,14 +27,18 @@ build() {
--enable-introspection=yes \
--enable-vala=yes \
--with-usb-ids-path=/usr/share/hwdata/usb.ids \
- --with-pci-ids-path=/usr/share/hwdata/pci.ids \
- || return 1
- make || return 1
+ --with-pci-ids-path=/usr/share/hwdata/pci.ids
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="c4f9e67bb5538e31e7d2ed3d764547ba0a2263da5bbf4d1ef930a32d5953fab59abc672e5f86a1f7f5ac1ebd0c5195986193f699a6b0efbcb6769917c0ed7102 libosinfo-1.1.0.tar.gz"