aboutsummaryrefslogtreecommitdiffstats
path: root/community/libowfat
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-10-25 20:12:37 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-10-25 21:19:11 +0200
commitabde00db46cd7767703bc023da33a2a7fda4f5ce (patch)
tree2f7511b24b84e8ecde11f9bb95349535aa631c8f /community/libowfat
parent6ae8e4414d963c8812c86c2eb0d26c2434a93bec (diff)
community/libowfat: move from main
Diffstat (limited to 'community/libowfat')
-rw-r--r--community/libowfat/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/libowfat/APKBUILD b/community/libowfat/APKBUILD
new file mode 100644
index 00000000000..e24489e7284
--- /dev/null
+++ b/community/libowfat/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net"
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libowfat
+pkgver=0.31
+pkgrel=0
+pkgdesc="Reimplementation of libdjbr"
+url="http://www.fefe.de/libowfat/"
+arch="all"
+license="GPL"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.fefe.de/$pkgname/$pkgname-$pkgver.tar.xz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make CFLAGS="-I. ${CFLAGS}" || return 1
+}
+
+package() {
+ cd "$builddir"
+ make prefix="$pkgdir"/usr \
+ MAN3DIR="$pkgdir"/usr/share/man/man3 \
+ install || return 1
+
+ # buffer manpage conflicts with openssl
+ mv "$pkgdir"/usr/share/man/man3/buffer.3 \
+ "$pkgdir"/usr/share/man/man3/owfatbuffer.3
+}
+
+md5sums="120798fab86cfd72dc6b12284d248dd0 libowfat-0.31.tar.xz"
+sha256sums="d1e4ac1cfccbb7dc51d77d96398e6302d229ba7538158826c84cb4254c7e8a12 libowfat-0.31.tar.xz"
+sha512sums="b3ce973d6edc501ddaa6caa84dc3b74e3e31ced92e4f707038858cd36c977863251a7eaeababdad34ffe6b8ad13c9702118464f6f9fd827e05f6fbc5004408b5 libowfat-0.31.tar.xz"