aboutsummaryrefslogtreecommitdiffstats
path: root/community/libphonenumber/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-13 12:33:45 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 11:26:31 +0000
commit3406e2b02b3e747fcf7d9773c0ff9cbbf503b549 (patch)
treecea4747027efedc16e8a45ae75f16fa94a943084 /community/libphonenumber/APKBUILD
parent86d8290fc91f76517cf90351fc95f3c08619dac9 (diff)
community/libphonenumber: upgrade to 8.12.1
Diffstat (limited to 'community/libphonenumber/APKBUILD')
-rw-r--r--community/libphonenumber/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/libphonenumber/APKBUILD b/community/libphonenumber/APKBUILD
index 03158459f91..a2163c8d97b 100644
--- a/community/libphonenumber/APKBUILD
+++ b/community/libphonenumber/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bhushan Shah <bshah@kde.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libphonenumber
-pkgver=8.12.0
-pkgrel=2
+pkgver=8.12.1
+pkgrel=0
pkgdesc="Library for parsing, formatting, and validating international phone numbers."
url="https://github.com/googlei18n/libphonenumber"
arch="all"
@@ -11,11 +11,11 @@ depends_dev="boost-dev protobuf-dev icu-dev"
makedepends="$depends_dev cmake gtest-dev"
checkdepends="gtest"
subpackages="$pkgname-static $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/libphonenumber/archive/v$pkgver.tar.gz"
+source="https://github.com/googlei18n/libphonenumber/archive/v$pkgver/libphonenumber-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver/cpp"
build() {
- cmake -B build . \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -27,7 +27,7 @@ check() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="629d68998aee0c32074f6f6e4bbeca29430e543b7c3be6bf0ab8fc6df5a6ab4eb85c406b3fef4afa395157d41a47fc46963a4c018258e32698b3266419c68265 libphonenumber-8.12.0.tar.gz"
+sha512sums="5803a2d71dbc5b1b39de14231b7ccdcf4067f82feb5854ec8ccc9efa69fdc9a168909a414701e143238199c2939398a408e3c912e075c092e24953f9d13314b5 libphonenumber-v8.12.1.tar.gz"