aboutsummaryrefslogtreecommitdiffstats
path: root/community/libstaroffice/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-08 14:30:39 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-08 14:30:39 +0000
commit8f0e5ecf332a2ea049d0e1151a20931217725726 (patch)
tree2f0bcea2c1c45ec656e951a56adfba9420fefe3d /community/libstaroffice/APKBUILD
parenta13840afc875b6e5059827d9e0c3ad3778cddfa3 (diff)
community/libstaroffice: new aport
Import filter for StarOffice documents https://github.com/fosnola/libstaroffice
Diffstat (limited to 'community/libstaroffice/APKBUILD')
-rw-r--r--community/libstaroffice/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libstaroffice/APKBUILD b/community/libstaroffice/APKBUILD
new file mode 100644
index 00000000000..c451bb90fb1
--- /dev/null
+++ b/community/libstaroffice/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libstaroffice
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Import filter for StarOffice documents"
+url="https://github.com/fosnola/libstaroffice"
+arch="all"
+license="MPL2"
+depends=""
+depends_dev="zlib-dev boost-dev"
+makedepends="$depends_dev librevenge-dev doxygen"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/fosnola/libstaroffice/releases/download/$pkgver/libstaroffice-$pkgver.tar.xz"
+builddir="$srcdir/libstaroffice-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0bd47f3cab084b3be208c014eff5c520 libstaroffice-0.0.2.tar.xz"
+sha256sums="762dc518690eaa1f946147e913476c3d852703357f3cdf90047dc79515651002 libstaroffice-0.0.2.tar.xz"
+sha512sums="a3bf46c3be3ebfd279dcb8fd8e66c40cdf719e5b19ce25dd7c5d0a1890b5e044c862718da63c5de4b8a6b41778e30ab4ee18c09d898f7edb8e6f518d329614da libstaroffice-0.0.2.tar.xz"