aboutsummaryrefslogtreecommitdiffstats
path: root/community/lld/APKBUILD
diff options
context:
space:
mode:
authorxentec <xentec@aix0.eu>2017-11-04 09:50:21 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 18:44:36 +0100
commitc5400f0769aa54629a427497676d3d40715694dd (patch)
tree3f0c0b353b874aa78b07845fcbcea040b13e1625 /community/lld/APKBUILD
parente62454f8396883a4148a6d9072f5b0e4e986d84d (diff)
[llvm]: build with MinSizeRel and our flags
Diffstat (limited to 'community/lld/APKBUILD')
-rw-r--r--community/lld/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/lld/APKBUILD b/community/lld/APKBUILD
index b30bde9031b..ea2f444ceb3 100644
--- a/community/lld/APKBUILD
+++ b/community/lld/APKBUILD
@@ -25,11 +25,13 @@ build() {
cd "$builddir"/build
cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_VERBOSE_MAKEFILE=OFF \
+ -DCMAKE_C_FLAGS_MINSIZEREL_INIT="$CFLAGS" \
+ -DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS" \
+ -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
+ \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DLLVM_INCLUDE_TESTS=ON
make