aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-coxpcall
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-09-11 17:25:23 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-09-11 17:25:23 +0200
commitd24966bb6c73fe3b915ec7dda80f140c16cabf4b (patch)
tree0bdaa4a67617c25d9136eb86f2ee6ecc9e5ec02e /community/lua-coxpcall
parentef67f4e6d5076293e7a6a370a6f83be3e9a5ef37 (diff)
community/lua-coxpcall: move from testing
Diffstat (limited to 'community/lua-coxpcall')
-rw-r--r--community/lua-coxpcall/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/lua-coxpcall/APKBUILD b/community/lua-coxpcall/APKBUILD
new file mode 100644
index 00000000000..a7e57c8c03b
--- /dev/null
+++ b/community/lua-coxpcall/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=lua-coxpcall
+_pkgname=coxpcall
+pkgver=1.16.0
+_pkgver=${pkgver//./_}
+pkgrel=0
+pkgdesc="Coroutine safe xpcall and pcall for Lua"
+url="http://keplerproject.github.io/coxpcall/"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/archive/v$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgver"
+
+_luaversions="5.1 5.2 5.3"
+for _v in $_luaversions; do
+ makedepends="$makedepends lua$_v-dev"
+ subpackages="$subpackages lua$_v-$_pkgname:_package"
+done
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_package() {
+ local lver="${subpkgname:3:3}"
+ pkgdesc="$pkgdesc $lver"
+ depends="lua$lver"
+ install_if="lua$lver $pkgname=$pkgver-r$pkgrel"
+
+ cd "$builddir"
+ make DESTDIR="$subpkgdir" LUA_DIR="/usr/share/lua/$lver" install || return 1
+}
+
+md5sums="1d25a2e5b0c0cd529b1fdc35dea2a06b lua-coxpcall-1.16.0.tar.gz"
+sha256sums="b732add4d8c2c56d82a176cf38c11ff1b799c02f220cb29dcd332b91adc34b16 lua-coxpcall-1.16.0.tar.gz"
+sha512sums="3c1661189cd583e181eb60abd6bf782c7c2d653ea487a8651601df205f52d71433d3f10c1f6a150ec09f44aae62b98265baadcb05bf7692487aeecab3527026f lua-coxpcall-1.16.0.tar.gz"