aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-http
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-20 01:06:59 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-20 01:06:59 +0100
commitcb69bc0b4cb1e4cbb05963f051fd2ddc2f013ebb (patch)
tree2c830d0702fd6c06d06a0e3e0042334d47fac745 /community/lua-http
parent0f3169c514d24e886fc78b4b38ab807e01a5bc35 (diff)
community/lua-http: don't rely on install_if in checkdepends
Diffstat (limited to 'community/lua-http')
-rw-r--r--community/lua-http/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/lua-http/APKBUILD b/community/lua-http/APKBUILD
index 28dd53ca157..cce8564fd54 100644
--- a/community/lua-http/APKBUILD
+++ b/community/lua-http/APKBUILD
@@ -8,7 +8,7 @@ url="https://github.com/daurnimator/lua-http"
arch="noarch"
license="MIT"
depends="lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns lua-ossl"
-checkdepends="lua-busted lua-compat53 lua5.1-bit32"
+checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53 lua5.1-bit32"
makedepends=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz"
@@ -24,8 +24,8 @@ esac
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
+ checkdepends="$checkdepends lua$_v lua$_v-busted"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
- checkdepends="$checkdepends lua$_v"
done
check() {