aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-lpeg
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-04-14 23:11:35 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-26 19:24:24 +0000
commit0b2f94f24af5800de8f48a9a029f2958563d95fa (patch)
tree34f1679468f0fab24f8782d3fbbe5b38e476f7c5 /community/lua-lpeg
parenta3026151ce8c795f306d4c8aa6e7bef3c0d6a297 (diff)
community/lua-lpeg: enable luajit on all arches
Diffstat (limited to 'community/lua-lpeg')
-rw-r--r--community/lua-lpeg/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/community/lua-lpeg/APKBUILD b/community/lua-lpeg/APKBUILD
index 3329d89b769..6c020232136 100644
--- a/community/lua-lpeg/APKBUILD
+++ b/community/lua-lpeg/APKBUILD
@@ -3,23 +3,18 @@
pkgname=lua-lpeg
_pkgname=lpeg
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Pattern-matching library for Lua"
url="http://www.inf.puc-rio.br/~roberto/lpeg"
arch="all"
license="MIT"
subpackages="$pkgname-dev"
+checkdepends="luajit"
source="http://www.inf.puc-rio.br/~roberto/lpeg/$_pkgname-$pkgver.tar.gz
test-fix-setlocale.patch
build-static-lib.patch"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x|aarch64) _luajit="";;
- *) checkdepends="luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
@@ -46,7 +41,7 @@ build() {
}
check() {
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions; do
msg "Testing on lua$lver"
cd "$builddir-${lver/jit/5.1}"