aboutsummaryrefslogtreecommitdiffstats
path: root/community/lucene++/APKBUILD
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-04-13 19:45:26 +0000
committerpsykose <alice@ayaya.dev>2022-04-13 21:45:38 +0200
commit4d1db64d7b7177d4c4560b24a1e70c6cedb0c666 (patch)
treea83af06c8129d9f8029a42498f4a88ab2a94d478 /community/lucene++/APKBUILD
parent24de023799b31b8ccfb79eaed906ba792fd9ebf4 (diff)
community/lucene++: set BUILD_TYPE=MinSizeRel and build with samurai
Diffstat (limited to 'community/lucene++/APKBUILD')
-rw-r--r--community/lucene++/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/lucene++/APKBUILD b/community/lucene++/APKBUILD
index fd0a70f92f8..1756988c6ad 100644
--- a/community/lucene++/APKBUILD
+++ b/community/lucene++/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lucene++
pkgver=3.0.8
-pkgrel=4
+pkgrel=5
pkgdesc="C++ port of the popular Java Lucene library"
url="https://github.com/luceneplusplus/LucenePlusPlus"
arch="all"
license="LGPL-3.0-or-later OR Apache-2.0"
depends_dev="boost-dev zlib-dev"
-makedepends="$depends_dev cmake linux-headers"
+makedepends="$depends_dev cmake linux-headers samurai"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.8.tar.gz
160.patch
@@ -20,17 +20,17 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlu
builddir="$srcdir/LucenePlusPlus-rel_$pkgver"
build() {
- cmake -B build . \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
-DCOTIRE_ADDITIONAL_PREFIX_HEADER_IGNORE_PATH=/usr/include/fortify
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
# Remove vendored gtest that lucene++'s buildsystem insists on installing
# together with it