aboutsummaryrefslogtreecommitdiffstats
path: root/community/lucene++/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-14 22:43:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-15 01:46:08 +0000
commit68ecf368a8aff9fd7acf5ecb92e501cf30d38a1d (patch)
tree7d3518d4e7ee60027b2d814d092ce669ded4f858 /community/lucene++/APKBUILD
parentae99ceef1a5c585b73ff4af414bcdd2aea6cfce0 (diff)
community/lucene++: upgrade to 3.0.8
Diffstat (limited to 'community/lucene++/APKBUILD')
-rw-r--r--community/lucene++/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/lucene++/APKBUILD b/community/lucene++/APKBUILD
index 84d042209d9..e7356a64064 100644
--- a/community/lucene++/APKBUILD
+++ b/community/lucene++/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lucene++
-pkgver=3.0.7
-pkgrel=13
+pkgver=3.0.8
+pkgrel=0
pkgdesc="C++ port of the popular Java Lucene library"
url="https://github.com/luceneplusplus/LucenePlusPlus"
arch="all"
@@ -12,15 +12,13 @@ makedepends="$depends_dev cmake linux-headers"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
-builddir="$srcdir/LucenePlusPlus-rel_$pkgver"
+builddir="$srcdir/LucenePlusPlus-rel_3.0.7"
build() {
cmake -B build . \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_DESTINATION=/usr/lib \
- -DBoost_LIBRARY_DIR=/usr/lib \
- -DENABLE_CUSTOM_ALLOCATOR='FALSE' \
-DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
-DCOTIRE_ADDITIONAL_PREFIX_HEADER_IGNORE_PATH=/usr/include/fortify
make -C build
@@ -30,4 +28,4 @@ package() {
make -C build DESTDIR="$pkgdir" install
}
-sha512sums="92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 lucene++-3.0.7.tar.gz"
+sha512sums="92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 lucene++-3.0.8.tar.gz"