aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-tweak
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-06 21:10:44 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-06 21:11:00 +0000
commit8b60d939fee2c044b18e2cefbcf2e4e250125992 (patch)
treef5fc35c2ee81bd361a5752df9b3e523f6c6727c3 /community/mate-tweak
parentdce38366db04f2ede81927e9ea004d62532122a4 (diff)
community/mate-tweak: move from testing
Diffstat (limited to 'community/mate-tweak')
-rw-r--r--community/mate-tweak/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/mate-tweak/APKBUILD b/community/mate-tweak/APKBUILD
new file mode 100644
index 00000000000..0aeeb87f987
--- /dev/null
+++ b/community/mate-tweak/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=mate-tweak
+pkgver=18.04.16
+pkgrel=0
+pkgdesc="Tweak tool for the MATE Desktop"
+url="https://github.com/ubuntu-mate/mate-tweak"
+arch="all"
+license="GPL-2.0"
+depends="python3 py-setproctitle"
+makedepends="python3-dev py-distutils-extra intltool"
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ubuntu-mate/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="33d10536e3c6f7b75d728fcc3513080f47183828c87403bd3445ac523f602f62ee40724b25ae0f399eea931f1dbb8c89625112d36861f4befd4a8caa7ab4f273 mate-tweak-18.04.16.tar.gz"