aboutsummaryrefslogtreecommitdiffstats
path: root/community/mktorrent/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 19:23:54 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 19:25:10 +0000
commit3ec83758f6aef7f1f2ce2313876b4ff0e1bab647 (patch)
tree0998743c762969ad7c0afddc24781458c5afd7ac /community/mktorrent/APKBUILD
parent2f7ca837e984144528c878da5d6547d38e13c426 (diff)
community/mktorrent: modernize and add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/mktorrent/APKBUILD')
-rw-r--r--community/mktorrent/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/mktorrent/APKBUILD b/community/mktorrent/APKBUILD
index 98db52a93cf..68f7aa074d2 100644
--- a/community/mktorrent/APKBUILD
+++ b/community/mktorrent/APKBUILD
@@ -2,20 +2,25 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=mktorrent
pkgver=1.1
-pkgrel=0
+pkgrel=1
pkgdesc="A handy tool for creating .torrent files"
url="http://borg.uu3.net/~borg/?mktorrent"
arch="all"
license="BSD"
-depends=""
makedepends="libressl-dev"
-install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/Rudde/mktorrent/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+
+builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./mktorrent -h > /dev/null
}
package() {