aboutsummaryrefslogtreecommitdiffstats
path: root/community/mmh
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-08-28 23:33:59 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-08-28 23:33:59 +0200
commitb339507046ba955f1fa55752aeb371c2a1d203d2 (patch)
tree2275ba2e9a6c2ffb3c2cca7a8ca25ab6e35ee45c /community/mmh
parent4a89828778ec910031d919ffe52b27d66b8c62c2 (diff)
community/mmh: move from unmaintained
Also upgrade to 0.3 and cleanup a bit.
Diffstat (limited to 'community/mmh')
-rw-r--r--community/mmh/APKBUILD50
-rw-r--r--community/mmh/symlinks.patch12
2 files changed, 62 insertions, 0 deletions
diff --git a/community/mmh/APKBUILD b/community/mmh/APKBUILD
new file mode 100644
index 00000000000..e4d04db8de5
--- /dev/null
+++ b/community/mmh/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=mmh
+pkgver=0.3
+pkgrel=0
+pkgdesc="MUA for users who like the unix philosophy"
+url="http://marmaro.de/prog/mmh/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="ncurses-dev autoconf flex"
+install=""
+subpackages="$pkgname-doc"
+source="http://marmaro.de/prog/${pkgname}/files/${pkgname}-${pkgver}.tar.gz
+ symlinks.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc/$pkgname \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib/$pkgname \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ make DESTDIR="$pkgdir" \
+ -C "$builddir" install || return 1
+}
+
+md5sums="880017112da72d7d67856c13a252d436 mmh-0.3.tar.gz
+4351aef49407471609d1ab6047cafae2 symlinks.patch"
+sha256sums="13e6be6ccbcd9b763fd20299e72f623498876c5ec069950e73af2803c82033d2 mmh-0.3.tar.gz
+bc91f0053297eeedb7dbffd5ca627cc6805f8b9987a4fd74c1eca5dee0a4666b symlinks.patch"
+sha512sums="e71585ce726733c808e8388b9fdf8e5c7fb86a309af358f6676ceac45ddb47bc17eedce9ce98a7e9c1d49456fcf4ff425761fb3ec3654f8c9f02f51ba37a5447 mmh-0.3.tar.gz
+d6b92f582a15a2664f275b32e6ddf827fd0176e5e289a27bb210e9c58e02fa159bdf26c01f1227dad64ec5fb55ab5aac4b86246ba66ef46c656749be2a11842f symlinks.patch"
diff --git a/community/mmh/symlinks.patch b/community/mmh/symlinks.patch
new file mode 100644
index 00000000000..f0679cc769a
--- /dev/null
+++ b/community/mmh/symlinks.patch
@@ -0,0 +1,12 @@
+diff -upr mmh-0.2.orig/uip/Makefile.in mmh-0.2/uip/Makefile.in
+--- mmh-0.2.orig/uip/Makefile.in 2015-12-21 03:41:33.425934861 +0100
++++ mmh-0.2/uip/Makefile.in 2015-12-21 03:42:09.715772415 +0100
+@@ -33,7 +33,7 @@ LEXLIB = @LEXLIB@
+
+ COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CFLAGS)
+ LINK = $(CC) $(LDFLAGS) -o $@
+-LN = ln
++LN = ln -s
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@