aboutsummaryrefslogtreecommitdiffstats
path: root/community/monkey/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 19:38:34 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 19:38:59 +0000
commit9f9700d7720117af73673f5d4e3433b2b2eab0ff (patch)
tree97f682b084bce98a7544185ef686d33757052923 /community/monkey/APKBUILD
parent3ec83758f6aef7f1f2ce2313876b4ff0e1bab647 (diff)
community/monkey: modernize and add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/monkey/APKBUILD')
-rw-r--r--community/monkey/APKBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/community/monkey/APKBUILD b/community/monkey/APKBUILD
index cc2621c32d8..9c775281fd6 100644
--- a/community/monkey/APKBUILD
+++ b/community/monkey/APKBUILD
@@ -3,22 +3,16 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=monkey
pkgver=1.6.9
-pkgrel=1
+pkgrel=2
pkgdesc="Monkey is a lightweight and powerful web server"
url="http://monkey-project.com/"
arch="all"
license="ASL 2.0"
-depends=""
-depends_dev=""
makedepends="cmake jemalloc-dev bash mbedtls-dev findutils"
-install=""
subpackages="$pkgname-doc $pkgname-dev"
-source="http://monkey-project.com/releases/1.6/${pkgname}-${pkgver}.tar.gz"
+source="http://monkey-project.com/releases/1.6/$pkgname-$pkgver.tar.gz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- cd "$builddir"
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -34,16 +28,20 @@ build() {
--sysconfdir=/etc/$pkgname \
--webroot=/var/$pkgname \
--logdir=/var/log/$pkgname \
- --pidfile=${pkgname}.pid || return 1
+ --pidfile=${pkgname}.pid
make
}
+check() {
+ cd "$builddir"
+ ./build/mk_bin/monkey --help > /dev/null
+ ./build/plugins/auth/tools/mk_passwd --help > /dev/null
+
+}
package() {
cd "$builddir"
make DESTDIR=$pkgdir install
install -Dm 755 "$builddir/monkey.init" "$pkgdir/etc/init.d/banana"
}
-md5sums="c401734985a936ee07dbff5eca7d176a monkey-1.6.9.tar.gz"
-sha256sums="f1122e89cda627123286542b0a18fcaa131cbe9d4f5dd897d9455157289148fb monkey-1.6.9.tar.gz"
sha512sums="3540a17fffe57a9d4b88b6243c634dcf6a27ed894ae2a0d5d42a4881221a9d59ae67d4c7fcf087535360d20ccdadab16947cf3a7dc6d4e864d487f598eb0ba62 monkey-1.6.9.tar.gz"