aboutsummaryrefslogtreecommitdiffstats
path: root/community/monkey/APKBUILD
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-09-13 07:00:07 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-12-29 09:59:13 +0000
commitdbcc4de9ee99ba5d796398881f6ba1d54ea6874a (patch)
tree29aeffcaae19d3fa2f2f8cafa4cbb74a75caa07b /community/monkey/APKBUILD
parent9c2376cca71f3342159e374d66950adab7632f80 (diff)
community/monkey: fixes ssl problem
Builds monkey with jemalloc to fix a seg fault issue when built with built-in malloc.
Diffstat (limited to 'community/monkey/APKBUILD')
-rw-r--r--community/monkey/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/community/monkey/APKBUILD b/community/monkey/APKBUILD
index 8e5446a3503..0b0adc6b5f1 100644
--- a/community/monkey/APKBUILD
+++ b/community/monkey/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
license="ASL 2.0"
depends=""
depends_dev=""
-makedepends="cmake bash mbedtls-dev findutils"
+makedepends="cmake jemalloc-dev bash mbedtls-dev findutils"
install=""
subpackages="$pkgname-doc $pkgname-dev"
source="http://monkey-project.com/releases/1.6/${pkgname}-${pkgver}.tar.gz"
@@ -25,9 +25,8 @@ build() {
./configure \
--musl-mode \
--no-backtrace \
- --malloc-libc \
--mbedtls-shared \
- --enable-plugins=tls \
+ --enable-plugins=tls,auth \
--default-user=nobody \
--prefix=/usr \
--libdir=/usr/lib \