aboutsummaryrefslogtreecommitdiffstats
path: root/community/mousepad
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 13:56:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 13:57:01 +0000
commit44afc3ce96aae18996bee8f920c1d477f4ef23f5 (patch)
tree175508cb08954d2bf69a9f87552c9670faf58a49 /community/mousepad
parentfffd21fe0d8c00125038212026856080529cd40f (diff)
community/mousepad: add check()
Diffstat (limited to 'community/mousepad')
-rw-r--r--community/mousepad/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/mousepad/APKBUILD b/community/mousepad/APKBUILD
index 85f207bfaea..e2c42859738 100644
--- a/community/mousepad/APKBUILD
+++ b/community/mousepad/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mousepad
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple Text Editor for Xfce4"
url="http://foo-projects.org/~benny/xfce/apps.html"
arch="all"
@@ -12,7 +12,6 @@ install=""
subpackages="$pkgname-lang"
source="https://archive.xfce.org/src/apps/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
"
-
builddir="$srcdir"/$pkgname-$pkgver
build () {
@@ -29,6 +28,11 @@ build () {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install