aboutsummaryrefslogtreecommitdiffstats
path: root/community/mtd-utils/APKBUILD
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-04-12 08:22:39 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-19 20:59:00 +0000
commit9a92e00856b85bd22f1bd0c51a7c5827d77617eb (patch)
tree2db0ae46efcf6e644e72a98ea80d183a95c42278 /community/mtd-utils/APKBUILD
parent6c10903577dc6c9b9768ba62c54701b1abd7c2c5 (diff)
community/mtd-utils: Version bump to 2.1.0
2.1.0 was released 4 weeks ago, so lets bump the version while we're here. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'community/mtd-utils/APKBUILD')
-rw-r--r--community/mtd-utils/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/community/mtd-utils/APKBUILD b/community/mtd-utils/APKBUILD
index 84442f5d6a9..2e2cc2e763a 100644
--- a/community/mtd-utils/APKBUILD
+++ b/community/mtd-utils/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=mtd-utils
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=0
pkgdesc="Utilities for handling MTD devices, and for dealing with FTL, NFTL JFFS2, etc."
url="http://www.linux-mtd.infradead.org/"
@@ -8,18 +8,28 @@ arch="all"
license="GPL-2.0-only"
makedepends="
acl-dev
+ autoconf
+ automake
+ libtool
linux-headers
lzo-dev
+ openssl-dev
util-linux-dev
zlib-dev
"
subpackages="${pkgname}-doc"
+_githash="1dba7944fe18978415a3ffc43932359a36b99b25"
source="
- ftp://ftp.infradead.org/pub/mtd-utils/${pkgname}-${pkgver}.tar.bz2
+ ${pkgname}-${pkgver}.tar.gz::http://git.infradead.org/mtd-utils.git/snapshot/${_githash}.tar.gz
+ 0001-unittests-test_lib-Include-proper-header-for-_IOC_SI.patch
+ 0002-unittests-libmtd_test-Include-fcntl-header.patch
+ 0003-unittests-Define-the-use-of-_GNU_SOURCE.patch
"
+builddir="${srcdir}/${pkgname}-$(echo "${_githash}" | cut -c1-7)"
build()
{
+ ./autogen.sh
./configure \
--build="${CBUILD}" \
--host="${CHOST}" \
@@ -34,6 +44,7 @@ package()
make DESTDIR="${pkgdir}" install
}
-md5sums="70b80fccdfc1b536a91deefb91f4e2be mtd-utils-2.0.0.tar.bz2"
-sha256sums="20a377aa86af4c102e930b0d0bb9859e3a10aeb16445f6a1273989b206a717c8 mtd-utils-2.0.0.tar.bz2"
-sha512sums="52d3fab58d254fd672f53b3f1868b19ca572a8f257fc86519d7afc7979776afa37c0f21d63cc9e9cdc2e342f1cfb2d077b07847f18f6484dc660077ee347f2fb mtd-utils-2.0.0.tar.bz2"
+sha512sums="bb64b6cbdaee3c731ed1dc136064507fbfffe8a45879b0c4024a2b46d320875252f42af8dc268b30247ebb81a7a89b951e19a896bb415de38877c45b031e1081 mtd-utils-2.1.0.tar.gz
+70013f50fad529e94733cd86349d4efe4d99c5febd7c407ab3db0c2995fd6be0524b3ebc59537ff13a4be9a8f63100468a9faa8590ea4d84f79995398b0fd7d9 0001-unittests-test_lib-Include-proper-header-for-_IOC_SI.patch
+eb6d72e2810218c90044f562ec2d58543f42066ca4719ec5c1199dfdebeacacbde931b59ad12a39df7834fb2b8cef240bed839840c11b3cac9761dd44e63bca8 0002-unittests-libmtd_test-Include-fcntl-header.patch
+e29c485a96b959c26f39a0a05a78e2a562f2bda0a2acc7ed532b6ebda46139f9e4c88b4df0f9dc13051dd5aa50ad60f82880f3da412b59d46fca527a88a30f5d 0003-unittests-Define-the-use-of-_GNU_SOURCE.patch"