aboutsummaryrefslogtreecommitdiffstats
path: root/community/multipath-tools
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-05 12:36:48 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-05 12:38:18 +0000
commitfc60db92aa27a9f4499ec826d29405aaa4b28e71 (patch)
tree14b61eb72edca214ced1b774f0fad12c28005057 /community/multipath-tools
parent6c74bd4eb210f48cac2a49a3ae58c604de52ed7a (diff)
community/multipath-tools: upgrade to 0.7.1
Disable RADOS since it's still in testing, modernize APKBUILD
Diffstat (limited to 'community/multipath-tools')
-rw-r--r--community/multipath-tools/0001-disable-rados.patch25
-rw-r--r--community/multipath-tools/APKBUILD54
-rw-r--r--community/multipath-tools/disable-rbd.patch14
-rw-r--r--community/multipath-tools/fix-yield.patch13
4 files changed, 37 insertions, 69 deletions
diff --git a/community/multipath-tools/0001-disable-rados.patch b/community/multipath-tools/0001-disable-rados.patch
new file mode 100644
index 00000000000..2f1c8be4f48
--- /dev/null
+++ b/community/multipath-tools/0001-disable-rados.patch
@@ -0,0 +1,25 @@
+From 490431efb3eb3a8746af5b3ad97797ae85b5bc0b Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Fri, 5 May 2017 12:14:35 +0000
+Subject: [PATCH] disable rados
+
+---
+ Makefile.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.inc b/Makefile.inc
+index 8361e6c..67fab53 100644
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -10,7 +10,7 @@
+ # WITH_LOCAL_LIBSYSFS = 1
+ #
+ # Uncomment to disable RADOS support (e.g. if rados headers are missing).
+-# ENABLE_RADOS = 0
++ENABLE_RADOS = 0
+ #
+ # Uncomment to disable libdmmp support
+ # ENABLE_LIBDMMP = 0
+--
+2.12.2
+
diff --git a/community/multipath-tools/APKBUILD b/community/multipath-tools/APKBUILD
index acba5f81d4f..d896b3d19aa 100644
--- a/community/multipath-tools/APKBUILD
+++ b/community/multipath-tools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname="multipath-tools"
-pkgver=0.6.3
+pkgver=0.7.1
pkgrel=0
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr/"
@@ -8,36 +8,19 @@ arch="all"
license="GPL"
depends="eudev"
makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev eudev-dev
- userspace-rcu-dev"
-install=
+ userspace-rcu-dev json-c-dev"
+_snapid="be1191b1d2726ed94498dac3505ca455bb6cb64e"
subpackages="$pkgname-doc"
-source="http://dev.alpinelinux.org/archive/multipath-tools/multipath-tools-$pkgver.tar.gz
- disable-rbd.patch
- fix-yield.patch
-
+source="$pkgname-$pkgver.tar.gz::http://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=$_snapid;sf=tgz
multipath-tools.conf
multipath-tools.confd
multipath-tools.initd
- "
-
-builddir="$srcdir"/multipath-tools-$pkgver
-snapshot() {
- cd "$srcdir"
- git clone http://git.opensvc.com/multipath-tools/.git
- cd multipath-tools
- git archive --format=tar.gz --prefix=multipath-tools-$pkgver/ \
- -o ../multipath-tools-$pkgver.tar.gz $pkgver \
- && scp ../multipath-tools-$pkgver.tar.gz dev.alpinelinux.org:archive/multipath-tools/
-}
-prepare() {
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ 0001-disable-rados.patch
+ "
+options="!check"
+_snapdirsuffix=$(echo $_snapid | cut -c1-7)
+builddir="$srcdir"/multipath-tools-$_snapdirsuffix
build() {
cd $builddir
@@ -55,21 +38,8 @@ package() {
install -D -m755 "$srcdir"/$pkgname.initd $pkgdir/etc/init.d/multipathd
}
-md5sums="0ed3487eb82b2b635b1a4fbd4057d43d multipath-tools-0.6.3.tar.gz
-7ddfcd64ee0b871a35cb72f22cc2b6bf disable-rbd.patch
-e19d7ed5492a23db6527fbc9c52198c3 fix-yield.patch
-d364a5ef62c23da92d81baf90e7b6192 multipath-tools.conf
-52dcde0446669e9d19813b28f3dd622b multipath-tools.confd
-e2032d8042fcc4b015b1dc1cc66cabe5 multipath-tools.initd"
-sha256sums="8a8dae70b7040e5c8bf187f3ab4113cf91a3644265bcca87f982befc6cec6ea1 multipath-tools-0.6.3.tar.gz
-7a1683035f65a6be6d4ec98ba77fbef95f5b518ada93d53f3cfe8fdc73d2e638 disable-rbd.patch
-805707a503a6ffda81c235ac1f3e986d52e16be75783839a02cb927f59423cec fix-yield.patch
-e5df29fc6cf01789db179e20aaac2705878975eb826157bd9f824a3f86a8dcd5 multipath-tools.conf
-b13587b0865ea8c39f51e2177e4fbc0ada237408a5807fab836ff4b5ebcb3e37 multipath-tools.confd
-bb7846f6c2bfdfb4ee50fe1965271909a9864b2b913d4892bb406d66f794ce9a multipath-tools.initd"
-sha512sums="669fa3f915da29769b21f8fa81227a4d8aefc779d54378b3899ec06d62508382ce8924978feb81b0b92abdcdf2c4b9206ea32f3231b7594475c4de76d13fb694 multipath-tools-0.6.3.tar.gz
-2460a2d0e3787a3862e9258c3821ac13819c7b1cbe03abc9b53a728ef502086692d643a15c655d6b73c909d917387548c08b182bc82d698e5b4c64a77b1e6858 disable-rbd.patch
-6f55b2c0ae6696ff819fc3f5ea5e59407db06bdac0097709034325e2a53cfd1025d4134df343f952bb13be4b1058b38ce54ffcb9e2faf2f53331afc529052cc1 fix-yield.patch
+sha512sums="473fa45314786b3c6183da03fe0a804f3e7fe75fd3ef8d20943806b8c721786becf9b16cd6449adb2243e851472f13d07eb50dce1d1fd404c7cf7abc72f0c039 multipath-tools-0.7.1.tar.gz
e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213 multipath-tools.conf
303c62b7506b207ba2266310e7a701d76151e6f1544b44faf666dfabdc59c5aeb98544d380988e18b4a7b8235e4000380f025c4dd6c95d45a7b8b51bbf39dce5 multipath-tools.confd
-1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c multipath-tools.initd"
+1ca0a8be7ddd0d57b810ab4905bc35d6b89b924ef528a7ee77dad162b86b990e0b86ef714f63857def4a61e30bfabe7a3980f624d63b80108408dd876a7c468c multipath-tools.initd
+2cdf669823d24fea230784fc911bf01942980ea04c611e973996ba6baa051c64ef5defc00161deccdf6ede45e3b38c526c6f6aaaf4ba9137c010ebbc1f97038f 0001-disable-rados.patch"
diff --git a/community/multipath-tools/disable-rbd.patch b/community/multipath-tools/disable-rbd.patch
deleted file mode 100644
index 892a49b18b1..00000000000
--- a/community/multipath-tools/disable-rbd.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/libmultipath/checkers/Makefile b/libmultipath/checkers/Makefile
-index 11ab76f..db276ef 100644
---- a/libmultipath/checkers/Makefile
-+++ b/libmultipath/checkers/Makefile
-@@ -13,8 +13,7 @@ LIBS= \
- libcheckdirectio.so \
- libcheckemc_clariion.so \
- libcheckhp_sw.so \
-- libcheckrdac.so \
-- libcheckrbd.so
-+ libcheckrdac.so
-
- all: $(LIBS)
-
diff --git a/community/multipath-tools/fix-yield.patch b/community/multipath-tools/fix-yield.patch
deleted file mode 100644
index e93d3bce259..00000000000
--- a/community/multipath-tools/fix-yield.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/multipathd/uxlsnr.c b/multipathd/uxlsnr.c
-index 7a9faf3..4e6a197 100644
---- a/multipathd/uxlsnr.c
-+++ b/multipathd/uxlsnr.c
-@@ -180,7 +180,7 @@ void * uxsock_listen(uxsock_trigger_fn uxsock_trigger, void * trigger_data)
- pthread_mutex_unlock(&client_lock);
- condlog(0, "%s: failed to realloc %d poll fds",
- "uxsock", 1 + num_clients);
-- pthread_yield();
-+ sched_yield();
- continue;
- }
- old_clients = num_clients;