aboutsummaryrefslogtreecommitdiffstats
path: root/community/mumble/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-04 21:48:12 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 13:02:38 +0000
commit34001bbdeb45f402e36725c2b6abb29d2b4d267f (patch)
treed10f31416c8c94c78c3e0ff7869792a816d64d5f /community/mumble/APKBUILD
parentab2e689ca265277d183ddcd729af431ee0f75456 (diff)
downloadaports-34001bbdeb45f402e36725c2b6abb29d2b4d267f.tar.gz
aports-34001bbdeb45f402e36725c2b6abb29d2b4d267f.tar.bz2
aports-34001bbdeb45f402e36725c2b6abb29d2b4d267f.tar.xz
community/mumble: update to 1.3.0_rc1 and move to Qt5
Diffstat (limited to 'community/mumble/APKBUILD')
-rw-r--r--community/mumble/APKBUILD56
1 files changed, 20 insertions, 36 deletions
diff --git a/community/mumble/APKBUILD b/community/mumble/APKBUILD
index 33f749a4f6..0d1ea0585f 100644
--- a/community/mumble/APKBUILD
+++ b/community/mumble/APKBUILD
@@ -2,49 +2,37 @@
# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=mumble
-pkgver=1.2.19
-pkgrel=9
+pkgver=1.3.0_rc1
+_pkgver=${pkgver/_/-}
+__pkgver=${pkgver/_rc1/}
+pkgrel=0
pkgdesc="Low-latency, high quality voice chat software"
url="https://wiki.mumble.info"
arch="all"
license="BSD-3-Clause"
options="!check"
-depends="qt-sqlite"
-depends_dev=""
-makedepends="qt-dev libsndfile-dev boost-dev avahi-dev protobuf-dev
- libxi-dev speex-dev speexdsp-dev libcap-dev"
+depends="qt5-qtbase-sqlite"
+makedepends="qt5-qtbase-dev libsndfile-dev boost-dev avahi-dev protobuf-dev
+ libxi-dev speex-dev speexdsp-dev libcap-dev alsa-lib-dev qt5-qtsvg-dev
+ qt5-qttools-dev opus-dev
+ "
install="murmur.pre-install"
pkgusers="murmur"
pkggroups="murmur"
subpackages="$pkgname-doc murmur murmur-doc:murmur_doc:noarch"
-source="https://github.com/mumble-voip/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- CVE-2018-20743.1.patch
- CVE-2018-20743.2.patch
- boost-1.66.patch
+source="https://github.com/mumble-voip/$pkgname/releases/download/$_pkgver/$pkgname-$_pkgver.tar.gz
murmur.initd"
-builddir="$srcdir"/$pkgname-$pkgver
-
-# secfixes:
-# 1.2.19-r9:
-# - CVE-2018-20743
+builddir="$srcdir/$pkgname-${pkgver/_rc1/}"
build() {
- cd "$builddir"
-
- CXXFLAGS="-std=c++11"
- qmake -recursive main.pro \
- CONFIG+="no-speechd no-g15 no-update no-ice bundled-celt no-embed-qt-translations no-bundled-speex"
-
- # qmake-qt4 ignores complation *FLAGS thus patch the Makefiles directly
- sed -i "s;^\(CXXFLAGS.*=.*\);& $CXXFLAGS;" \
- */Makefile* */*/Makefile*
+ qmake-qt5 -recursive main.pro \
+ CONFIG+="no-speechd no-g15 no-ice bundled-celt no-embed-qt-translations no-bundled-speex no-bundled-opus no-rnnoise" \
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble"
make release
}
package() {
- cd "$builddir"
-
# Binaries.
install -Dm755 ./release/mumble \
"$pkgdir"/usr/bin/mumble
@@ -52,16 +40,14 @@ package() {
"$pkgdir"/usr/bin/mumble-overlay
# Libraries.
- install -Dm755 ./release/libmumble.so.$pkgver \
- "$pkgdir"/usr/lib/mumble/libmumble.so.$pkgver
+ install -Dm755 ./release/libmumble.so.$__pkgver \
+ "$pkgdir"/usr/lib/mumble/libmumble.so.$__pkgver
for lib in libmumble.so libmumble.so.1 libmumble.so.1.2; do
- ln -s libmumble.so.$pkgver \
+ ln -s libmumble.so.$__pkgver \
"$pkgdir"/usr/lib/mumble/$lib
done
install -Dm755 ./release/plugins/liblink.so \
"$pkgdir"/usr/lib/mumble/liblink.so
- install -Dm755 ./release/plugins/libmanual.so \
- "$pkgdir"/usr/lib/mumble/libmanual.so
install -Dm755 ./release/libcelt* \
"$pkgdir"/usr/lib/mumble/
@@ -110,13 +96,11 @@ murmur_doc() {
cd "$builddir"
install -Dm644 ./man/murmurd.1 \
"$subpkgdir"/usr/share/man/man1/murmurd.1
+ gzip "$subpkgdir"/usr/share/man/man1/murmurd.1
+
install -Dm644 ./LICENSE \
"$subpkgdir"/usr/share/licenses/murmur/LICENSE
- default_doc
}
-sha512sums="f91111194a899149b500a94afcf7cc5b9691c7ce8669f07fca2c66adbb3916ddb863bf703d04fb8387133fb75f3c8edb52974d1acf3febfafa1f73da19946de4 mumble-1.2.19.tar.gz
-6a3c78a479c795f91fabd557c34249308e1032be51ee668a9576cb8d2f7028526c4d79895b5053822c05f998e147a0577e801e8a27c9a454a4473193f16de943 CVE-2018-20743.1.patch
-9e2b0dcb5ca34aea1607e0561446bced93e13ce296df986855299f7b652e99db8f9504e0dfa6544e8f443996b8a78a912328f4924813a4716028a8323c70d6d0 CVE-2018-20743.2.patch
-fcdaf2a3575e3871fe4003b93364a70a7c7029beb64ba5e24931abbe3898b72791848b5cf78ccf48eee5942a37f696a5134d061c2b8d60b66913abd701758330 boost-1.66.patch
+sha512sums="e993b18b0ecf620d3a9a89f145c18b9ecde3aaf9b7217e235b7472908c81a365323c8683dd6fc9ed14b108160f8bf5244369c2a9ee57c22595550220d158516c mumble-1.3.0-rc1.tar.gz
c74ade232146a180448cb0027503f59642000bee50613a1fb99162cdc4bc81089ab4e84e51b0bbdac5c176eb52b76e6bd2b3ec790a9148135a1fc050569921c3 murmur.initd"