aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-27 00:31:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-27 02:32:42 +0200
commit32550b2d944a12ecb9133478ae1735176ac6dff4 (patch)
tree6d1120cff4983ec69d1e385809046937d51dbc9c /community/nextcloud/APKBUILD
parent8e7fc822dee6c3ce7cca4b83a81020e98138dcdf (diff)
community/nextcloud: file_sharing needs federatedfilesharing
Diffstat (limited to 'community/nextcloud/APKBUILD')
-rw-r--r--community/nextcloud/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 13b0b1d057d..87d7686c1ec 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -177,10 +177,12 @@ _package_app() {
local php_deps=$(xmlstarlet sel -t -v 'info/dependencies/lib/text()' "$appinfo" \
| xargs -r -n1 printf "$_php-%s\n")
- depends="$pkgname $php_deps"
+ local app_deps=""
- # XXX: Provides/replaces for backward compatibility with <12.0.0-r2.
case "$appname" in
+ files_sharing) app_deps="-federatedfilesharing";;
+
+ # XXX: Provides/replaces for backward compatibility with <12.0.0-r2.
files_pdfviewer | files_texteditor | files_videoplayer)
provides="$pkgname-${appname#files_}"
replaces="$provides"
@@ -191,6 +193,8 @@ _package_app() {
;;
esac
+ depends="$pkgname $php_deps ${app_deps//-/$pkgname-}"
+
mkdir -p "$subpkgdir"/$_appsdir
mv "$pkgdir"/$_appsdir/$appname "$subpkgdir"/$_appsdir/
}