aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-23 13:10:08 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-23 13:10:29 +0200
commitb8a78f4ff716fe4aa2cc0dd69e1a6f2e90b6d5d5 (patch)
treecf4932eba2f72f415ef848c7f9af3fbf4d712cd5 /community/nodejs-current/APKBUILD
parent7b2ac1850d39f7592fac3115fc9c4cc803c3ff24 (diff)
nodejs-current: add basic check
Diffstat (limited to 'community/nodejs-current/APKBUILD')
-rw-r--r--community/nodejs-current/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 24a962789e2..f3a7fcc16aa 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -43,13 +43,25 @@ build() {
make -C out mksnapshot BUILDTYPE=Release
paxmark -m out/Release/mksnapshot
make
+
+ # paxmark so JIT works
+ paxmark -m out/Release/node
+}
+
+# TODO Run provided test suite.
+check() {
+ cd "$builddir"/out/Release
+
+ ./node -e 'console.log("Hello, world!")'
+ ./node -e "require('assert').equal(process.versions.node, '$pkgver')"
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- # paxmark so JIT works
+
+ # It's strange, but it really needs to be paxmarked again...
paxmark -m "$pkgdir"/usr/bin/node
cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share