aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-31 22:33:38 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-10-31 22:59:46 +0100
commitc87d137b7794a3182a9cf68ed7aeb3a688afe11b (patch)
tree89268fe542249caa9d4071c625cc691df0095883 /community/nodejs-current
parentb2439926247c823e609c4a17a326d3d40d55ebc0 (diff)
community/nodejs-current: remove -npm subpackage
npm is a separate project, it's just bundled with nodejs, so it doesn't make much sense to provide two npm versions. Eventually I'll move npm into a separate package.
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD22
1 files changed, 4 insertions, 18 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index e520a659edf..f3e819ba9f7 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -13,7 +13,7 @@ depends_dev="libuv"
# gold is needed for mksnapshot
makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev linux-headers
paxmark binutils-gold http-parser-dev ca-certificates c-ares-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-npm::noarch"
+subpackages="$pkgname-dev $pkgname-doc"
provides="nodejs"
replaces="nodejs nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
@@ -63,23 +63,9 @@ package() {
# It's strange, but it really needs to be paxmarked again...
paxmark -m "$pkgdir"/usr/bin/node
- cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share
- local d; for d in doc html man; do
- rm -r "$pkgdir"/usr/lib/node_modules/npm/$d
- done
-}
-
-npm() {
- pkgdesc="A package manager for JavaScript"
- depends="$pkgname"
- provides="nodejs-npm"
- replaces="nodejs-npm $pkgname" # $pkgname for backward compatibility
-
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/npm "$subpkgdir"/usr/bin/
-
- mkdir -p "$subpkgdir"/usr/lib/node_modules
- mv "$pkgdir"/usr/lib/node_modules/npm "$subpkgdir"/usr/lib/node_modules/
+ # Remove npm, it's provided by main/nodejs package.
+ rm -r "$pkgdir"/usr/lib/node_modules
+ rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
sha512sums="dbaecaf9aec9efe51df7a4fb7c2c987fd93d2aac8254e520f702e352aa483124e4f047afef13f3db3a4b10284aa39fd9e250fc9d5a441020d3e85c331007d75f node-v9.0.0.tar.gz