aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 18:50:23 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 18:58:41 +0200
commit886a9e0eea800c464204aaed624e7efd3100d3b3 (patch)
tree12b85ec60e5db2b9bf276a9c3dd2c68d453df8b3 /community/notmuch
parentc83ab8bd1422b96a1491afc21c03388fb299699e (diff)
community/notmuch: add emacs subpackage
Diffstat (limited to 'community/notmuch')
-rw-r--r--community/notmuch/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 047f0b9f40c..8cd37832151 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.24.1
-pkgrel=3
+pkgrel=4
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
@@ -15,6 +15,7 @@ subpackages="
$pkgname-doc
$pkgname-libs
$pkgname-vim:vim:noarch
+ $pkgname-emacs:emacs:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
@@ -70,6 +71,17 @@ vim() {
prefix="/usr/share/vim/vimfiles" install
}
+emacs() {
+ depends="emacs notmuch"
+ pkgdesc="Emacs plugins for $pkgname"
+
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/emacs/ "$subpkgdir"/usr/share/emacs/
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/notmuch-emacs-mua "$subpkgdir"/usr/bin/
+}
+
bashcomp() {
depends=""
pkgdesc="Bash completions for $pkgname"