aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml-camlp4
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 17:59:30 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-09 18:27:24 +0100
commit8530b1bd92515675782ad22333ef86cc1c97754c (patch)
treee781c9080a3b2551823715c23842a68aac21a269 /community/ocaml-camlp4
parent056306161c32f1c4fcac537c82bad1945d30277a (diff)
community/ocaml-camlp4: rename camlp4 to ocaml-camlp4
Diffstat (limited to 'community/ocaml-camlp4')
-rw-r--r--community/ocaml-camlp4/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
new file mode 100644
index 00000000000..ea97256ea9d
--- /dev/null
+++ b/community/ocaml-camlp4/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer: Anil Madhavapeddy <anil@recoil.org>
+pkgname=ocaml-camlp4
+_pkgname=camlp4
+# NOTE: camlp4 version must match ocaml version!
+pkgver=4.04
+_versuffix='+1'
+_pkgver=$pkgver$_versuffix
+pkgrel=1
+pkgdesc="Caml preprocessor and pretty-printer"
+url="https://github.com/ocaml/camlp4/releases"
+arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
+license="LGPL-2.0-or-later-WITH-linking-exception"
+depends="ocaml"
+makedepends="ocamlbuild"
+replaces="camlp4" # for backward compatibility
+provides="camlp4=$pkgver-r$pkgrel" # for backward compatibility
+source="$_pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
+
+build() {
+ cd "$builddir"
+
+ ./configure
+ make -j1 all camlp4/META
+}
+
+package() {
+ cd "$builddir"
+
+ make BINDIR="$pkgdir/usr/bin" \
+ LIBDIR="$pkgdir/usr/lib/ocaml" \
+ PKGDIR="$pkgdir/usr/lib/ocaml" \
+ install install-META
+}
+
+sha512sums="7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776 camlp4-4.04+1.tar.gz"