aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 15:36:47 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:25 +0100
commit20208f5263351fae4fac1d26dd15b2d49be62257 (patch)
treeeb6cbbfec34ff35aefa95877e7702e4bc161cce7 /community/ocaml
parent85f8b3d1175c4a611df8c9757bd927557cc86f9a (diff)
community/ocaml: rename ocamldoc to ocamldoc.byte, add symlink
Diffstat (limited to 'community/ocaml')
-rw-r--r--community/ocaml/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 622eae53815..060239c084d 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -55,13 +55,19 @@ package() {
LIBDIR="$pkgdir"/usr/lib/ocaml \
MANDIR="$pkgdir"/usr/share/man
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+
+ cd "$pkgdir"
+
# Remove annotation files and sources.
- find "$pkgdir"/usr/lib/ocaml \
+ find usr/lib/ocaml \
\( -name '*.cmt' -o -name '*.cmti' -o -name '*.ml' \) \
-a -delete
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+ # To be consistent with other binaries.
+ mv usr/bin/ocamldoc usr/bin/ocamldoc.byte
+ ln -s ocamldoc.opt usr/bin/ocamldoc
}
ocamldoc() {