aboutsummaryrefslogtreecommitdiffstats
path: root/community/offlineimap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-01 17:02:58 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-01 17:02:58 +0100
commitbb150f87cad59cca5aaea3c40d7ada25ebeff37a (patch)
tree129f00147ccbb00cf48d942132cb2bbf47760a04 /community/offlineimap
parent28ec1afcd7a39cb2f78246762c69de549d089a4e (diff)
community/offlineimap: move from main
Diffstat (limited to 'community/offlineimap')
-rw-r--r--community/offlineimap/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/offlineimap/APKBUILD b/community/offlineimap/APKBUILD
new file mode 100644
index 00000000000..2939db6075d
--- /dev/null
+++ b/community/offlineimap/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer:
+pkgname=offlineimap
+pkgver=7.1.4
+pkgrel=1
+pkgdesc="Synchronizes emails between two repositories"
+url="http://www.offlineimap.org"
+arch="noarch"
+license="GPL2+"
+depends="python2 py2-six"
+makedepends="python2-dev asciidoc"
+install=""
+options="!check"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/OfflineIMAP/${pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+
+ cd "$builddir"/docs
+ make man
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --root="${pkgdir}" \
+ --optimize=1
+
+ for man in docs/*.?; do
+ install -Dm644 "$man" \
+ "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
+ done
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 README.md TODO.rst MAINTAINERS.rst Changelog.md \
+ "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 offlineimap.conf* \
+ "$pkgdir"/usr/share/doc/$pkgname/examples/
+}
+
+sha512sums="f2623a400de2fac339249f887529e1f02224ba40c5f739b4084b5b26d1f8b6f26faf2c248aeaecd48dd7f6cc27bdaa8b7691c10f3db3b9673a1a5338f435447c offlineimap-7.1.4.tar.gz"