aboutsummaryrefslogtreecommitdiffstats
path: root/community/omxplayer/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-07 13:56:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-07 13:56:09 +0000
commit69e0f45f2280af0ef8e2f192363ebd3bfbc42eb3 (patch)
tree08dd1ffea0bdd6d5e425290ce7aee76efba37d46 /community/omxplayer/APKBUILD
parent26aa4de397292ac7cf30da476e1909e4129f340b (diff)
{main => community}/omxplayer: move
Diffstat (limited to 'community/omxplayer/APKBUILD')
-rw-r--r--community/omxplayer/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/omxplayer/APKBUILD b/community/omxplayer/APKBUILD
new file mode 100644
index 00000000000..1b29522f42b
--- /dev/null
+++ b/community/omxplayer/APKBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=omxplayer
+pkgver=0.20161017
+_commitid=2ee17b22a6149a043a2e402580504f282c615373
+pkgrel=1
+pkgdesc="Commandline OMX player for Raspberry Pi"
+url="https://github.com/popcornmix/omxplayer"
+arch="armhf"
+license="GPL-2.0"
+depends="ttf-freefont"
+makedepends="linux-headers raspberrypi-dev ffmpeg-dev pcre-dev
+ boost-dev freetype-dev dbus-dev alsa-lib-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-dbg"
+source="omxplayer-$pkgver.tar.gz::https://github.com/popcornmix/omxplayer/archive/$_commitid.tar.gz
+ issue-260.patch
+ issue-297.patch
+ fix-makefile.patch
+ default-font.patch
+
+ omxplayer.initd
+ omxplayer.confd
+ "
+
+builddir="$srcdir"/$pkgname-$_commitid
+
+build() {
+ cd "$builddir"
+ cat <<EOF > Makefile.include
+INCLUDES:=-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux
+INCLUDES+=$(pkg-config --cflags freetype2 dbus-1)
+LDFLAGS:=-L/opt/vc/lib -Wl,-rpath,/opt/vc/lib
+LIBS:=$(pkg-config --libs freetype2 dbus-1)
+STRIP:=echo
+EOF
+ make omxplayer.bin
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/doc/omxplayer
+ cp omxplayer.bin $pkgdir/usr/bin/omxplayer
+ cp COPYING $pkgdir/usr/share/doc/omxplayer
+ cp README.md $pkgdir/usr/share/doc/omxplayer/README
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="75a19d29e037d87b17edfe631590ba8e9035dc3ee8114e0398531f7f5fbfbc2947044ec56290dbeff90bba3e8231590b70270e39fcb2e1a91ca698c69e9aa02c omxplayer-0.20161017.tar.gz
+c349eea5f7c513a07d82a6cf6467c4d21bcb29c053bc5e39d8f675b1212db9beef0abf5248d50ac5a2f14fda73055786f94f421377ffcf5f6bcf8daa2f1b56e8 issue-260.patch
+2a8a6def1e09f726cba58c0b9109fa6c4fbd4a3b4f1d27d200488f262a0e0978579d83db7fe24f1d3e03beef318c3674ed79cbd2f1994c4551a59c9fe0f63489 issue-297.patch
+009ae8398755417d1a13ed15bcfdc6ce43fb637db153c51c15b00ef0edf82117dfb2964d5e37e0baf30e4ef1e3003546ae39e42a492e75fcdfc15d751e1ad516 fix-makefile.patch
+8aa58aaa07453186302dc68d92f28c1b50bf0f8fccd50359640a7fc8339b233b32a0c8c02284a9974599e56d69cc557acc25e76e6438c6d64d15afd9c1788a8e default-font.patch
+3ddd32235d87a46478d0237ee9b253edeb75729e377b09a33069ecdca2ee230d2851f308897ee75ff69a9f3bdd2876f490bc1667a572dce1c186f80fddcf6df3 omxplayer.initd
+4f906ada035869a0e515e7615056b18b0f6906ce4b3a2d34081c0efa79bb9455380f729e7c5270180f5ace89c53a7ac7c93f609e6761825f639f44aa22346bb2 omxplayer.confd"