aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 00:02:35 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:25 +0100
commit51804ebea879ff3d782b12c6e68c63c51c06fabf (patch)
tree671dbbb7276ab33155c937f4538c283b0fd1391b /community/opam
parentbf4ce0560062162a6ff38031eaec9ad1a55e89fd (diff)
downloadaports-51804ebea879ff3d782b12c6e68c63c51c06fabf.tar.gz
aports-51804ebea879ff3d782b12c6e68c63c51c06fabf.tar.bz2
aports-51804ebea879ff3d782b12c6e68c63c51c06fabf.tar.xz
community/opam: rebuild with ocaml 4.06.1
Diffstat (limited to 'community/opam')
-rw-r--r--community/opam/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index b16097d7c0..7c7f52982e 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Michael Zuo <muh.muhten@gmail.com>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
+# FIXME: lib-ext downloads dependencies; package them and use system-provided!
pkgname=opam
pkgver=1.2.2
-pkgrel=3
+pkgrel=4
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-3.0"
depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
-makedepends="ocaml-camlp4-dev"
+makedepends="ocaml-compiler-libs ocaml-camlp4-dev"
source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
fix-default-stubsdir.patch"
builddir="$srcdir/$pkgname-full-$pkgver"
@@ -24,7 +25,10 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
- make -j1 lib-ext all
+
+ # -unsafe-string needed to make it build with ocaml >=4.06.
+ OCAMLFLAGS="-unsafe-string" \
+ make -j1 lib-ext all
}
package() {