aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-12-20 06:59:49 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-12-20 06:59:49 +0000
commit17b1863302ef99ea004a61cbf341c17a23ce3743 (patch)
tree07132b726b4e499d316df9954c77b02647c0d916 /community/openjdk7/APKBUILD
parent7e6fbe1a9a64371fd292a62b2f64112ffd31e0a2 (diff)
community/openjdk7: fix hotspot build with gcc8
There is at least one (possibly more) places where signed overflow needs to work or things break. It is formally UB, but fortunately there is compiler flag to not break things when possible. Fixes build on x86_64.
Diffstat (limited to 'community/openjdk7/APKBUILD')
-rw-r--r--community/openjdk7/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 70342d01739..5443cb32c83 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -6,7 +6,7 @@ _icedteaver=2.6.14
# pkgver is <JDK version>.<JDK update>
# check icedtea JDK when updating
pkgver=7.181.$_icedteaver
-pkgrel=1
+pkgrel=2
pkgdesc="OpenJDK 7 via IcedTea"
url="https://icedtea.classpath.org/"
arch="all"
@@ -133,10 +133,10 @@ build() {
# Explicitly set the C++ standard as the default has changed on GCC 6+
# and disable optimizations that lead to a broken JVM. These options
# has been adopted from the Fedora package.
- export EXTRA_CPP_FLAGS="$CXXFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ export EXTRA_CPP_FLAGS="$CXXFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-strict-overflow"
# CXXFLAGS doesn't make it to all calls, so we set the C++ standard
# version for C too.
- export EXTRA_CFLAGS="$CFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ export EXTRA_CFLAGS="$CFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-strict-overflow"
local patch
for patch in $source; do