aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk8
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-26 01:27:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-26 01:27:51 +0100
commit0722b351e9d6ba1c35de0fba065386e7a355edbb (patch)
treed24997d7ba9ef0bc6e3d0470b7ef5c00cbc0d2ee /community/openjdk8
parent1876fe8971d38a74c717a130bb96e064d902d76c (diff)
community/openjdk8: do not fail when classes.jsa doesn't exist
This is related to new version of abuild running with `set -e`. The build failed on armhf; classes.jsa is apparently not generated on this platform and hence failed to be removed.
Diffstat (limited to 'community/openjdk8')
-rw-r--r--community/openjdk8/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 4b9f6922e6c..b12e86dc400 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -158,7 +158,7 @@ package() {
# This archive contains absolute paths from the build environment,
# so it does not work on the target system. User can generate it
# running `java -Xshare:dump`.
- rm "$pkgdir"/$_jrelib/server/classes.jsa
+ rm "$pkgdir"/$_jrelib/server/classes.jsa || true
# pax mark again (due to fakeroot xattr handling bug)
./pax-mark-vm "$pkgdir"/$_java_home true || return 1