aboutsummaryrefslogtreecommitdiffstats
path: root/community/opusfile/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 09:17:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 15:55:32 +0000
commit2c4b767c4fb49294a747be87b48bb20a06444a50 (patch)
treeaa92856c1d147ca4db0407f4b260184d085dd1c7 /community/opusfile/APKBUILD
parentb43c0f2c41358639994e61387db7edc49c8b0a9e (diff)
community/opusfile: move from main
Diffstat (limited to 'community/opusfile/APKBUILD')
-rw-r--r--community/opusfile/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/opusfile/APKBUILD b/community/opusfile/APKBUILD
new file mode 100644
index 00000000000..d3f1db43b18
--- /dev/null
+++ b/community/opusfile/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=opusfile
+pkgver=0.11
+pkgrel=2
+pkgdesc="High-level API for decoding and seeking within .opus files"
+url="https://www.opus-codec.org/"
+arch="all"
+license="BSD-3-Clause"
+depends_dev="openssl-dev"
+makedepends="$depends_dev libogg-dev opus-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.xiph.org/releases/opus/opusfile-$pkgver.tar.gz
+ fix-conflict.patch
+ "
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ec3e282310cc4f25475c27b7bc8d1652dcb25d3ac6badf87bd1b4e5397fbe106a0dab81c60d88d198003a23d8a2c9bae8b661edc9b31433effeca438ce56a349 opusfile-0.11.tar.gz
+b902b8c25506d3730a2a3bafcc5542671df8f35c588d05e54e883071c853c2e6e572dde80a8f7f39a58780a509c2d14b963040a3cab633edfc400cfca08060de fix-conflict.patch"