aboutsummaryrefslogtreecommitdiffstats
path: root/community/osmo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-17 09:17:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-17 09:17:15 +0000
commita8f23b4bc7717f483e52c25fb5fa9606de486805 (patch)
tree384668d16e473ad8584940f34847b5b5e2ec0dec /community/osmo
parentdd15f1bf4a82141ccac02436bf7d5eb0e73fb2cb (diff)
community/osmo: upgrade to 0.4.0
Diffstat (limited to 'community/osmo')
-rw-r--r--community/osmo/APKBUILD45
-rw-r--r--community/osmo/osmo-0.2.10-build-mo.patch20
2 files changed, 65 insertions, 0 deletions
diff --git a/community/osmo/APKBUILD b/community/osmo/APKBUILD
new file mode 100644
index 00000000000..0f400b4822a
--- /dev/null
+++ b/community/osmo/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=osmo
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="A handy personal organizer"
+url="http://clayo.org/osmo/"
+arch="all"
+license="GPL"
+makedepends="gtk+3.0-dev libnotify-dev libical-dev libxml2-dev libxml2-utils
+ autoconf automake"
+install=
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://downloads.sourceforge.net/$pkgname-pim/$pkgname-$pkgver.tar.gz
+ osmo-0.2.10-build-mo.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i##*/}"
+ patch -p1 -i "$i" || return 1
+ done
+ sed -i -e 's/-Werror//' configure.ac || return 1
+ aclocal && autoconf && automake --add-missing
+}
+
+build() {
+ cd "$_builddir"
+ CFLAGS="$CFLAGS -I/usr/include/libical"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="b6a20322c17d352e1168c537f850a461c0cc4e5c9edb87d69647a6b9d5e3f5e2c14ec5fe6bb2c87f7b2f4b3fccf15871ca5be698e6f46832e590ba14493b2ef8 osmo-0.4.0.tar.gz
+c9e49a3177f6135b2cedc00b0bc36ef7421a34941349bcfe242702dcfb5ebf13907d0ae8f8af1e26065b21e53f29e69c1fe36fd6724bfbb86556c3df828c8f23 osmo-0.2.10-build-mo.patch"
diff --git a/community/osmo/osmo-0.2.10-build-mo.patch b/community/osmo/osmo-0.2.10-build-mo.patch
new file mode 100644
index 00000000000..ac1b9aa235e
--- /dev/null
+++ b/community/osmo/osmo-0.2.10-build-mo.patch
@@ -0,0 +1,20 @@
+diff --git a/po/Makefile.am b/po/Makefile.am
+index b3c904a..f0ee467 100644
+--- a/po/Makefile.am
++++ b/po/Makefile.am
+@@ -16,8 +16,8 @@ all: $(MOFILES)
+
+ update-po: $(DOMAIN).pot $(POFILES) $(MOFILES)
+
+-%.mo: skip
+- @po=$(@:.mo=.po); if test $$po -nt $@ ; then $(MSGFMT) -c --statistics $$po -o $@; echo "$@ updated."; fi
++%.mo: %.po
++ @$(MSGFMT) -c --statistics $^ -o $@; echo "$@ updated."
+
+ %.po: $(DOMAIN).pot
+ $(MSGMERGE) $@ $< -o $@.in && mv $@.in $@
+@@ -41,4 +41,3 @@ uninstall-local:
+ clean-local:
+ rm -rf *.mo
+
+-skip: