aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-acunetix/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:03:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:03:23 +0000
commite1e04cce4705d3ac86b2807c8afedbed6a6d23cf (patch)
tree0db30641c424f209d111554bd08c89c4466ef7a3 /community/ospd-acunetix/APKBUILD
parent56d7b871078afb2c19999312c7e2024aa994cc77 (diff)
community/ospd-acunetix: moved from testing
Diffstat (limited to 'community/ospd-acunetix/APKBUILD')
-rw-r--r--community/ospd-acunetix/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/ospd-acunetix/APKBUILD b/community/ospd-acunetix/APKBUILD
new file mode 100644
index 00000000000..48e8732c41b
--- /dev/null
+++ b/community/ospd-acunetix/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-acunetix
+pkgver=1.0b1
+pkgrel=0
+_pkgid=2181
+pkgdesc="OSP server implementation to allow OpenVAS to remotely control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev cmake py-setuptools"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="155898fa60914ed84c9d09b28463417f ospd-acunetix-1.0b1.tar.gz"
+sha256sums="4c2b13056f38626952cc22b7b085025b237ee723d8b35bce2350ce51c52653ae ospd-acunetix-1.0b1.tar.gz"
+sha512sums="2a5b6fde959a890cd2084d1f8414639f8d281c3456239f101d1f353ec4044142cf71d7f7788a4d9aa0ce5d7a8a33204b785f5fd5d372d5c661e1ba9b9a447fd3 ospd-acunetix-1.0b1.tar.gz"