aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-ssh-keyscan
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:35:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:35:58 +0000
commitb8b501f77d5643217951fc62bcc97053ec8306dc (patch)
treea256653bcac7dc13cbc88fb7a77fb16b44b0f02b /community/ospd-ssh-keyscan
parent6f80948d30961158e51850e627e42ec0599c995e (diff)
community/ospd-ssh-keyscan: added check, modernized APKBUILD
Diffstat (limited to 'community/ospd-ssh-keyscan')
-rw-r--r--community/ospd-ssh-keyscan/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/ospd-ssh-keyscan/APKBUILD b/community/ospd-ssh-keyscan/APKBUILD
index 72f3eebfa13..8037d27f957 100644
--- a/community/ospd-ssh-keyscan/APKBUILD
+++ b/community/ospd-ssh-keyscan/APKBUILD
@@ -9,22 +9,23 @@ url="http://openvas.org/"
arch="noarch"
license="GPLV2+"
depends="python3 ospd"
-depends_dev=""
makedepends="python3-dev py3-paramiko"
-install=""
-subpackages=""
source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}