aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-crypt-rc4
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-24 12:45:55 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-24 12:45:55 +0000
commitb7604327e738fd36f3b6fea57305586acb098005 (patch)
treeda2bfe80310fc1e9ed11058f07c5a6b4e2e7adea /community/perl-crypt-rc4
parent5bd7095f8a777176273e1ef65e9d89287139f356 (diff)
community/perl-crypt-rc4: modernize and add package description
Diffstat (limited to 'community/perl-crypt-rc4')
-rw-r--r--community/perl-crypt-rc4/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/perl-crypt-rc4/APKBUILD b/community/perl-crypt-rc4/APKBUILD
index 4f60d4d2911..3d89e901d12 100644
--- a/community/perl-crypt-rc4/APKBUILD
+++ b/community/perl-crypt-rc4/APKBUILD
@@ -4,35 +4,40 @@
pkgname=perl-crypt-rc4
_pkgreal=Crypt-RC4
pkgver=2.02
-pkgrel=0
-pkgdesc="unknown"
+pkgrel=1
+pkgdesc="Perl implementation of the RC4 encryption algorithm"
url="http://search.cpan.org/dist/Crypt-RC4/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SI/SIFUKURT/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}